Stuck on Shelly 1 button [SOLVED]

Hello everyone. I just purchased a shelly button. The web interface says 2 but in HA it say one. I have enabled CoIT and I have been able to add it to HA, but after that I cannot really do anything with it. I think I am missing something. In HA it looks like this

And the web interface shows this

Do I need to enable each press? What about the url to “hit”?

Here is the CoIT

Any help is appreciate as I cannot get this to work and I am not sure how I am suppose to make it work.


The Shelly button generates events not entities. See:

Much appreciated tom! Thank you for taking the time to help and link out :slight_smile:
The link says that clicks should show up in the logs, but when I click, no logs. Do you know if the clicks should show up in the logs? If yes, then I need to trouble shoot some where else.

I don’t have any Shelly buttons but yes I would imagine that the events should show up on the Logbook panel (not Settings → Logs).

You need to go to the event listener under the dev tools and filter on the Shelly event type.

You have to use device automation trigger, click this blue plus icon next to the Automations title.

Thank you. So here is the event listener and it looks like there is nothing labeled shelly or if I try to search shelly I don’t see anything. Also when I push the button, nothing changes…

Got it!

So I created a little automation to test stuff out and it seems like HA isn’t detecting the buttons clicks. I have reloaded the yaml config, but no improvement. Here is what I see after clicking the button many test times.

alias: Button turn on recirculating pump
description: ""
  - platform: device
    device_id: 2bde7bccb98f9d1161bf0a1a653985d5
    domain: shelly
    type: double
    subtype: button
condition: []
  - type: turn_on
    device_id: 6853a0110b7e4ebdbb803cb0a089b9df
    entity_id: switch.smartplug_with_energy_monitor
    domain: switch
  - delay:
      hours: 0
      minutes: 5
      seconds: 0
      milliseconds: 0
  - type: turn_off
    device_id: 6853a0110b7e4ebdbb803cb0a089b9df
    entity_id: switch.smartplug_with_energy_monitor
    domain: switch
mode: single

Not sure why the button isn’t showing clicks in HA.

Which integration are you using? The official Shelly one? If you’re going pure MQTT you’ll need to inspect the topics with a broker tool and build the MQTT sensor config.

I did restart HA last night and so now I see the

I’m pretty sure that I am using the official integration.

Again thank you for everyone helping out. Still very new at this and I only have short time periods to work on between work and family.

I think that I need to find a way to check to see if HA is getting the button click first. How do I do this? I thought it was thorough events, but I cannot seem to figure out how to use event listeners to see what is happening and logs do not help in this case

Listen to events:

Then press your button and watch the page.

It worked!!!

Thank you for the help! Now I feel like I know that it is getting to HA and just need to go on from there.

So here is what I created

alias: Turn on light with Shelly Button
description: ""
  - platform: event
condition: []
  - service: light.turn_on
      brightness_pct: 50
      device_id: be917bcc64ede08c87e4c3456d8e32d8
mode: single

But I now want to be able to do different things with different button clicks. I see in the listen events there is data. Can I put that into the data area here?

Do I need to put all of it or can I just put the Click_Type?

Never mind! It totally worked! This is so COOL! Thanks again for the help

Now if someone could tell me what the light pattern means on the button or how to get the action to happen faster after the button trigger. Seems to take about 10 seconds for the action to happen. Button blinks fast light blue, then solid green sometimes them solid blue for a bit.

Hi, there, @stevedennis. I struggle with the same issue as you did with your Shelly Button 1, I guess. I have successfully added the Button1 to HA, but cannot figure out how to configure multiple button moves. I do have the event under events, but when pushing the Shelly Button, no log/info appears in the Listen to Events section. Could you elaborate on how you solved this?

Sure. I’ll have time over the weekend to take a look

I have the same issue. But I have read this blog a couple of times but do not understand how the problem was solved.

Could you add an explanation on how this problem was solved?


1 Like

Same here.
I have the listeners in Dev tools and tried multiple solutions to create the click automation.
I found out, that the listener always gets the “long” push but not the single, doube or triple.
Any one stuck on the same issue? So automations triggered by the long push work totally fine. I also tried changing the max time between multi push but nothing helped.

Thx for any suggestions

After my reply yesterday, today is available a new beta firmware update: 20230913-113105/v1.14.0-gcb84623
After downloading this update everything works fine including single, double and even triple click.