Stuck on the basics

I am a complete novice and there are probably thousands out there.
The posts here are far too complex for me and looking for a solution for the issue I have is impossible… I have been mucking around trying to get HA set up for 6 to 8 months…
The issue is I have Hasbian installed on the Rasp Pi. The bottom line on the screen says homeassistant@hassbian:home/pi
How do I get a nice picture image I can work with on the Rasp pi screen…
I cant connect on the IPad or the Macbook Pro because since the installation of the Beta software on both of those the system seems to be locked down tight and beyond my ability.
I am sure that will eventually be sorted out but for now I would like a nice picture of Home Assistant on the Rasp Pi so I can configure the thing… Or at least try to… :wink:

Open up a web browser on any computer on your local network. Navigate to:


Where IPADDRESS is the ip address of the pi you have installed home assistant on.

1 Like

You want to read the Hassbian docs.

Amongst other things, you’ve got a typo (active should be activate) and you start the service with systemctl.

1 Like

So why not install hassio? It’s easier to install.

I m going to have to… This installation has me beat… I started with hassio but could not get the wifi connected even though I tried multiple versions of the instructions using a usb thumb drive.
The issue might be the fact that I am a Mac user and adding the ‘instructions’ to the files on the usb drive havent been properly explained in the earlier instructions. I then came across an article stating that I had to download Atom to write the boot file correctly (I think)…
I will start again with hassio and see how it all goes…
Dont go too far away please as I may need some further information :blush:

Stop using wifi. Plug it in!


Bugga… Is there a reason for your ‘no confusion statement?’

Once I have run hassos on the Ras Pi do I log in on the Pi to continue setting it up?
The Pi is asking me to log in but ‘pi and raspberry doesnt work’

If you’re using with HassOS then there’s no Raspbian, no pi user.

The system you create when you write hassio (or even raspbian etc.) are intended to be run headless. There is no local interface, even the command line should be accessed remotely as Tom suggests.
Wi-Fi is possible and fairly easy to do but you can’t beat a wired connection as nick says.
Who is Bugga ?
You boot it up wait maybe an hour, I can’t remember how long mine took (anyone got more recent experience? (or just a better memory?)) but keep trying to connect from a browser as Tom told you.
The Web page you open up is your interface.
You do ‘most’ of your interacting that way.
You need to configure samba, so you can see the file system and write files to it.
Explore that Web interface, read the docs (as tinkerer says), search the forum for anything you don’t understand and then ask us questions

1 Like

No. You use another computer on the network to browse to http://ipaddressofpi:8123 or http://hassio.local:8123 (pretty much just like the documentation tells you to do).

Correct. HassOS isn’t running Raspbian, and there is no pi user, and there is no reason for you to log in to the pi itself unless you are troubleshooting issues. If you need information on logging in locally to HassOS, I would suggest, again, reading the documentation.

I don’t know why you would have to use Atom for that, as Mac OS is a pretty good OS when it comes to respecting UNIX files. It’s pretty much only Windows crap that would format a file incorrectly (if used with word pad or notepad)

1 Like

When you say “search the forum for anything you don’t understand” it leaves it wide open for me… I am an absolute beginner with about 10 months practice :crazy_face::crazy_face:
I have now installed hassbian on my raspberry pi and it tells me (on the attached screen) that homeassistant is running… So I go back to my IPad Pro to log on but neither the iPad or the Apple Mac notebook Pro are unable to see the Pi… I scan with Fing but the Pi does not come up… I logged into the router and see the dns as, so I try that on the MacBook and the IPad… No Go… I have a feeling that as I am using the latest Apple Beta Software it might be a case of the latest software adding more security measures…
6 months ago I could access the homeassistant running on the Pi via the iPad. That is now not possible, yet… I may have to dabble in the security settings…

I just noticed that you asked, “who is Bugga” gotta laugh, it’s an Aussie term for “Oh Shit”… hahahaha

1 Like

Rather than say “search the forum” I will say RTFM [1]

Start here

Then read all the pages here (some of them may be overly complex for a beginner, but they do give you a very good view of how HA works).

And of course before asking questions, read this How to help us help you - or How to ask a good question

[1] Read The Fine Manual

1 Like

Nick, That’s the first time I’ve heard it called “fine”.


  1. Put the SD card in your SD card reader.
  2. Open balenaEtcher, select the image and flash it to the SD card.
  3. Unmount the SD card and remove it from your SD card reader.
  4. Only if you want to configure WiFi or a Static IP (requires USB stick):
  • Format a USB-Stick to FAT32 with volume-name CONFIG .
  • Create a folder named network in the root of the newly formatted USB-stick.
  • Within that folder create a file named my-network without extension.
  • Copy one of the examples to the my-network file and adjust accordingly.
  • Plug the USB-stick into the Raspberry Pi 3.
  1. Insert the SD card into your Raspberry Pi 3. If you are going to use an Ethernet cable, connect that too.
  2. Connect your Raspberry Pi to the power supply, so it turns on.
  3. The Raspberry Pi will now boot up, connect to the Internet and download the latest version of Home Assistant, which will take about 20 minutes.
    8. Home Assistant will be available at http://hassio.local:8123. If you are running an older Windows or have stricter network configuration, you might need to access Home Assistant at http://hassio:8123.
  4. If you have used a USB-stick for configuring the network, it can now be removed.

Install, unless you have a very specific need for Hassbian, which based on your limited knowledge and experience, no offense, you don’t.

Your syntax implied it was a person you where responding to, okay I will read “Bugger” when I come across “Bugga”
The IP address’s you have listed are not local class C address’s
I’m assuming you did as Nick suggested and let the Pi boot on your local network, then update itself (that’s what takes the time). So assuming this is in a domestic situation, your modem/router/dhcp thingy should have issued an address in the range. Use a network scanner or follow Moe’s instruction : -

The web server on the pi will provide you with the interface you need.
A lot of people use Atom from Mac’s but TextEdit is perfectly ‘fine’ and built it.
When you used this, I assume you were writting directly to the SD card ? If so, that’s okay, did you set an ip address ? (just making sure that you were assigned on by dhcp and you haven’t put a fixed one your network doesn’t know about and won’t talk to).
You don’t need to wangle any security settings to talk to a local host on your local netwoork assuming you are using another local host on the same network.
So (also, just to be sure) you are trying to use a browser to talk to the pi at the addresses / host described by moe aren’t you ?

Ooops, cross posted with Jason (love the “Tank Girl” Avatar)
Yes do what he says, HASSOS is the best option for you, I run that too.

Are you referring to me?

Yup !
It is from Tank Girl isn’t it ?

Lol. Nope. I’ve had this avatar since back when I used to play Battlefield Bad Company 2, I took a stock game image and put a Kangaroo head on it, because, you know, my game name was Kanga Who and I’m aussie. :slight_smile: This was the pic I believe I used.

Sorry for the off topic. :expressionless: