Stuck with IP address change - web UI not accessible

New to all of this.
Installed yesterday on windows virtual box, and could access the web UI via an ip address A (given during DHCP)
Overnight the router assigned that IP to another device, and the home assistant server got another address B, which wasn’t accessible for web UI. Device had address B but home assistant thought it was still address A.
So I set router to reserve address C for that device, and it gave it C, and configured home assistant to use static address C.
Now I can log into the webUI via http://homeassistant.local:8123 but not address C
It says it’s address C when HA server boots up and when I type network info, but won’t serve web requests to http://C:8123
Tried to browse through the yaml config but not reference to ip addresses
Feel I’m going around in circles, any solutions?

Try to ping homeassistant.local and if responds, it should respond with an IP address. Then ensure that you are using the replying address (hopefully this is address C) and see if that is working.
ping homeassistant.local

Did that from the server command line:

C:\Users\Simon>ping homeassistant.local
Pinging homeassistant.local [fe80::2fbe:4b6e:ee4:ad58%3] with 32 bytes of data:
Reply from fe80::2fbe:4b6e:ee4:ad58%3: time=1ms

The machine actually has as its assigned IP address (address C)

But in the config in HA web UI it displays:


IP Address:
Method: auto
Name Servers:,


IP Address: fe80::2fbe:4b6e:ee4:ad58/64
Gateway: fe80::3660:f9ff:fe20:70b1
Method: auto

So basically, the machine has the right IP address but HA still uses the old original address.

Not sure of the next step to force it to use the correct one. Tried rebooting the virtualbox/image but still came back up the same

Let’s see, you have a Windows machine as a Host that has a given IP address, and you have HA as a guest via Virtual Box which should be using a different IP address.

From your Host Windows machine, do the following:

  • Get the Host’s IP addresses using ipconfig
  • Get HA’s IPv4 addresses using ping -4 homeassistant.local

What do you get?

Are you 100% certain the IP is x.x.x.100? In your post you indicated that the web UI indicated x.x.x.53.
Have you tried ?

1 Like

What you’ve described is…

You’ve told the router to assign address C.


This plus

Says your HA box is configured (and working) on either or via the ip6 address

This is expected if you have a reservation in the router but have manually assigned an ip on the client side.

Id connect to the box by name and manually assign the IP address you want because it’s acting like it’s currently manually assigned to x.53/22.

1 Like