Studio Code Server: An unexpected error occurred that requires a reload of this page

Hello,

since a few days I can’t start Studio Code Server on any browser like brave or firefox.
I will get this error message

An unexpected error occurred that requires a reload of this page.
The workbench failed to connect to the server (Error: Time limit reached)

Log from Studio Code Server:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Add-on: Studio Code Server
 Fully featured Visual Studio Code (VSCode) experience integrated in the Home Assistant frontend.
-----------------------------------------------------------
 Add-on version: 5.0.1
 You are running the latest version of this add-on.
 System: Home Assistant OS 7.6  (amd64 / qemux86-64)
 Home Assistant Core: 2022.4.7
 Home Assistant Supervisor: 2022.04.0
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] code-server.sh: executing... 
[cont-init.d] code-server.sh: exited 0.
[cont-init.d] mosquitto.sh: executing... 
[cont-init.d] mosquitto.sh: exited 0.
[cont-init.d] mysql.sh: executing... 
[cont-init.d] mysql.sh: exited 0.
[cont-init.d] user.sh: executing... 
[cont-init.d] user.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[18:12:57] INFO: Starting the code server...
[2022-04-30T16:12:57.486Z] info  Wrote default config file to ~/.config/code-server/config.yaml
[2022-04-30T16:12:57.913Z] info  code-server 4.3.0 09bc30027a7fbba170f907a527eaa9f7219fe739
[2022-04-30T16:12:57.914Z] info  Using user-data-dir /data/vscode
[2022-04-30T16:12:57.935Z] info  Using config file ~/.config/code-server/config.yaml
[2022-04-30T16:12:57.935Z] info  HTTP server listening on http://0.0.0.0:1337/ 
[2022-04-30T16:12:57.936Z] info    - Authentication is disabled 
[2022-04-30T16:12:57.936Z] info    - Not serving HTTPS 
[18:16:20] Extension host agent started.

I didn’t change anything in the last couple of weeks. I only installed the newest updates from home assistant and esphome and so.

Does someone hast an idea how to fix this?

I updated my apache proxy.

An explanation of the problem and the solution would be helpful.

2 Likes

Did you find a solution? I uninstalled VSCode in HA and reinstalled. I click start but it doesn’t start. The last few lines of the log are similar to yours.

1 Like

How so? did you change a configuration parameter?

Same here, I’m using nginx proxy manager with authelia for authentication.