Succesfull Hassio installation on NUC with Proxomox and working bluetooth

After many… many… tries… finally I completed a Hassio installation on my NUC with working bluetooth.


  • Intel NUC 8i3BEH
  • 8 gb RAM
  • SSD Silicon Power A55 256 GB


  • Proxmox 6.0
  • Ubuntu Server 18.04
  • Hassio v. 0.102.3

Step by step installation:

  1. download Proxmox from official site
  2. copy image to a usb stick using Etcher Balena
  3. put usb stick in the NUC and install Proxmox
  4. test Proxmox is working at http://your_proxmox_ip:8006
  5. download Ubuntu Server iso from and save on your disk
  6. on the left menu of Proxmox click on “nuc-local” and then on “Load” button… and load the Ubuntu Server iso image
  7. on the upper right menu of Proxmox click on “Create VM”, choose the name, 32 GB disk, 2 GB RAM, and min 1 cpu.
  8. click on start, open shell and follow installation of Ubuntu (select only minimal configuration item)
  9. when installation was completed open a terminal window and execute these commands:
sudo apt install jq curl dbus socat bash avahi-daemon
sudo apt install apt-transport-https ca-certificates curl software-properties-common
curl -fsSL | sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] bionic stable"
apt-cache policy docker-ce
apt-get update
sudo apt install docker-ce
  1. about internal bluetooth of the NUC download drivers:
    and copy them in /lib/firmware/intel then shutdown and start VM
  2. in Proxmox VM click on Add button then in USB devices, add the device 8087:0aa7 to your VM.
  3. shutdown and start VM

and then install Hassio…

curl -sL | bash -s -- -m intel-nuc

In Hassio you will detect bluetooth deviced if you configured device_tracker

Using of Ubuntu Server instead of simple docker or Debian is needed becouse in my NUC I experienced that internal bluetooth or Asus BT400 dongle drivers cause errors and does not works.


Thanks for sharing :ok_hand: – Using a similar setup

Can you share your experience regarding performance of the NUC 8i3BEH? Does it handle all the tasks well?

Planning to acquire same kind of setup to also load a bunch of dockers including plex, medusa, ngnix, grafana etc… is the 8gb memory sufficient as you need to allocate several gb’s to virtual images?

Thank you for sharing.

Was searching around for other people using nuc’s. Not many around but I think most are quite happy with it?

Reason is quite simple > I can’t really trust the install on an sd card anymore, got one corrupted and it took me the better part of the day to get everything up and running again.

Currently running on a Rpi4, thought about booting that from ssd, but that’s also a cost. I’ve still got a 120GB M2 and 8GB DDR3 laying about doing nothing, and a matching nuc (older model NUC6CAYB but works with DDR3) would set me back 121€. And I would get my Rpi4 back for other stuff…

  1. about internal bluetooth of the NUC download drivers:
    and copy them in /lib/firmware/intel then shutdown and start VM

How do you do this? When I Git Clone the link to the directory it says it cannot do that because there are already files in there.

  1. in Proxmox VM click on Add button then in USB devices, add the device 8087:0aa7 to your VM

Does your NUC have USB Bluetooth? Mine has AC-Wireless 7265, which is PCI based.

I got my HA installed on a nuc two weeks ago. No big issues so far.

I was aware that bt could become an issue, but I had already moved my (very few) bt devices to esphome. I have an esp32 that handle the bluetooth communication. Planning to add some more for the range.

EDIT Looks like I’m going to have to swallow my words here: can’t do initial install of firmware anymore, because usb devices are no longer visible from Esphome… much like bluetooth I gues

1 Like

how to use wifi instead network lan?

I have Intel NUC 8i5BEH with Proxmox and Home Assistant OS 5.11 as VM. I tried your guide but unfortunately it didn’t work for my NUC. It seems that HA OS doesn’t use that drivers.

About the bluetooth drivers.
Use WinSCP to login and upload the files. root/(your password)

Protocol: SCP
Hostname: IP of proxmox server
Port: 22

I have HA running on Proxmox (on a Nuc) but unable to use bluetooth. Are these still the steps to make it work? On Proxmox /lib/firmware/intel the following files exist: ibt-11-5.ddc/sfi and ibt-12-16.ddc/sfi. Should I import ibt-17-16-1.ddc/sfi? How? Or what would be the other steps to enable bluetooth in HA?


Hi there,

Huge thanks for this thread who helped me to set up bluetooth (internal, not a USB DONGLE) on my NUC running proxmox.

Let me share my experience :

I set up a new VM with ubuntu server and ran hciconfig -a which gave me no results
I then followed point 10 of vpomax procedure (I had to overwrite files that were already there) and then hciconfig -a gave me the attended result with the bluetooth interface showing up.

I stopped thre because I had an other VM with home assisstant OS already set up with Passive BLE monitor for my Xiaomi BT thermometers. Unfortunately I had a message in logs saying that BT interface was not detected. Without downloading firmawares from github, I simply went to add USB device and I found the 8087:0aa7 and add it. After booting again the VM all my thermometers were magically appearing in lovelace.

Hi i tried with filezilla and Winscp but seems my root password isn’t recognized by winscp, on the terminal it works.

How did you give root permissions to a user?