Suddenly my Home Assistant is not reachable from internet


in the last few days, my interned connection was “bumpy”… up, down, slow …

not sure if this is related, but as result my home assistant is not anymore reachable, while it is still fully working (at leas the ZigBee stuff…)

I have configured everything with the duckDNS add-on, hence LAN/WAN access is with an external URL

how can I investigate what happened? I can I access the web interface? shoudl I remove the firewall rules? how do I deactivate duckdns (so at least locally I can access)?

thank you all

You can get access to HA by plugging in a keyboard and monitor directly to the host.
From there you can get a list of commands with ha help or edit your files. With ha addons you will be able to disable or remove your addons. I’m not sure if nano is preinstalled, but if it is, you can use nano FILENAME to edit files.
You could also try to access HOST_IP:4357 in order to access the observer

does it means that only internet access is not working?

I will try with the keyboard and monitor :slight_smile: and see what I can do

I’m not familiar with duck DNS, but I think so.
The logs will tell us more

I managed to get access to the internal IP address… I deleted DuckDNS add-on and restarted the server…

When I tried to update the system I got this (internet error):

which log should I look into?

thank you

What do you mean by internal IP? You can access it inside your home network?
If that works I would double-check the settings of the router.

You could also try to ping a server outside of your network to ensure you have a basic internet connection. For example google which would be ping in the cli.

Another thing to try would be to check the IP config in HA (Supervisor → system) against the IP config in your router. If you have configured a static IP and another device with that same IP, those two will fight each other

As you have UI access now, you can just go to config → Logs

since the 3rd no new errors… might be since then the internet problem…

any suggestion? please

Check your internet settings under supervisor → system → ip address


Still no luck on trying yo update the OS

What is your DNS set when you click on ‘Change’ next to ip address ?

which is correct :frowning:

Have you tried setting it to DHCP?
If you haven’t reserved the IP it could happen that HA will be reachable from another address. You would have to look that up in your router or reserve it before changing.

tried now… new IP .141 (found it with a scam tool), but I cannot access HA anymore (with the new IP :frowning: )

now I have completely screw my installation :frowning:

Are you sure the subnet is the same? The safest approach would still be to look it up in your router

I was going to say, set dns to, and disable ipv6. But I see you changed something else already.

with DHCP it is working now… I got a network scan tool to find the new IP…

the issue is that if the IP will change I will lose the port forwarding in the firewall… :frowning:

I am really confused

Make a DHCP reservation. That way the IP won’t change.

1 Like

thank you! but what can be the issue? it definitely seems to be Home assistant… because everything else in the network work fine…