Sun sensor problem

HA 0.40.0 Not sure when this started as I seldom click on this sensor.

My automations based on sun still seem to work.

config.yaml is set as


Working OK here on 0.40. Give a try at clearing your browser cache and see if it helps.

I did see this on my Alarm (Manual) control the other day but a restart and browser cache clear seems to have fixed it.

Cleared cache, tried different browsers and rebooted. Same, same.

Not sure about this in the log

File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/helpers/", line 148, in _async_setup_platform
    entity_platform.async_schedule_add_entities, discovery_info

I think though it may have something to do with squeezebox…not related it looks like.

Ok this is bizarre. I went to Configuration > Configuration Reloading > Reload Core and now…

Ta Da!

However this happened on the exact same minute the sun went below horizon. So not sure for sure what fixed it.

Did you restart since daylight savings time a few days ago?

Probably not. Anyway it has been perfect to date.