Supervised HA install on RPi4 + Debian, now wifi is gone?

I have just finished standing up Debian + a Supervised HA install and restoring HA from a previous backup of my setup (HassOS default setup/image on a different SD card to preserve it).

About the time when I triggered the HA install, dpkg -i homeassistant etc etc, I appear to have lost Wifi connectivity on Debian.

At all times that I’ve had the Pi4 and run HassOS, WiFi has worked as expected and continued to do so through the install process as I was wireless when I was grabbing things with apt-get/wget etc

I notice now when I boot the Pi that Debian will throw “Initializing XFRM netlink socket” and ip a shows me that it never picks up an IP

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 86:2b:64:04:91:b9 brd ff:ff:ff:ff:ff:ff permaddr dc:a6:32:a5:bd:e9

Whilst I have managed to get this far, I haven’t played with CLI Linux for 20yrs, some assistance to troubleshoot would be great.

iwconfig shows;

wlan0 IEEE 802.11 ESSID:“WLAN”
Mode:Managed Frequency:2.437 GHz Access Point: 50:C7:BF:0E:BF:99
Bit Rate=5.5 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=70/70 Signal level=-14 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:24 Invalid misc:0 Missed beacon:0

Dos that not imply it’s connected? Yet there’s no IP and I cannot ping the ip it should have (static based on MAC).

I can also scan and see networks using iwlist.

Try in Supervisor → System → Next to IP Address there is a button ‘Change’
Normally you can enable WiFi there.

Tried this as that was how i set it last time.

It just says this.


but the logs themselves dont have anything useful?


The debian install guide I followed had steps for setting up wifi as part of the install, editing /etc/network/interfaces.d/wlan0 which seem to upset HA and wifi in general.

I re-commented those edits out, rebooted, then used nmtui to connect to wifi once it was obvious i could san/see everything properly from debian, after that i rebooted again and HA is now visible again on the wifi IP.

Hope this helps someone else.