Supervised install

I’m running a supervised install of HA on a RPI4 (SSD).
I’ve been having troubles updating HA since May 2022.

Recently I run

ha resolution info

and got this:

- enabled: true
  slug: network_interface_ipv4
- enabled: true
  slug: backups
- enabled: true
  slug: free_space
- enabled: true
  slug: supervisor_trust
- enabled: true
  slug: dns_server
- enabled: true
  slug: core_security
- enabled: true
  slug: addon_pwned
- enabled: true
  slug: dns_server_ipv6
- context: system
  reference: null
  type: trust
  uuid: 4b8fc82c658d424e9f3f256edb019ad2
- auto: true
  context: system
  reference: null
  type: execute_integrity
  uuid: 4dd3c08865f04690a91001c6256674c1
unhealthy: []
- systemd_journal
- cgroup_version
- connectivity_check

Could someone please explain me what the issue is and how to resolve it?

Also, the items under “unsupported”, what do they mean? How do I resolve them?

Thanks in advance!

In the newer builds there is a menu section issues with links, but if your version is too old, then it might not have it and it might then be placed in the supervisor menu.

The menu section lists the same unsupported issues and then have a link to a homepage with the actions to correct it.
Here are the ones I could find.

Thanks for those links!

I was able to resolve the connectiviy check issue.
For Systemd I don’t feel so confindent deleting the OS and reinstalling.
And the GCroup version I can’t get it to work by running the installer again.

I tried following these instructions:

Create /etc/default/grub and add systemd.unified_cgroup_hierarchy=false
That’s what I did. I am running supervised install on Raspberry OS.
EDIT: I also have systemd.unified_cgroup_hierarchy=0 set in /boot/cmdline.txt which I remember doing recently to fix the cgroup V1 issue that came up in supervisor.

But that didn’t help much since the ouput of this command

docker info | grep ‘Cgroup Version’

results in:

Cgroup Version: 2
WARNING: No memory limit support
WARNING: No swap limit support

So the version doesn’t change back to V1.

Do you have another advices for those two points?

Not sure what to do with the systemd other then to reinstall.
Supervised install is only supported on Debian 11.
If you have Debian 10, then look up on google have to update the OS. it is just a few apt commands.

Regarding the cgroup issue, then it might take some time for the checks to be run, but before that you should restart the entire host with HA, not just HA core.

I’m running RaspberryPiOS. Which I know is “unsupported” but still based on Debian11.

Already tried restarting the host, still the same results.

Which checks do you recommend?

Are you sure your Raspbian OS is the Debian 11 version?
They were pretty slow to get it updated to that version.
I think it should be supported, because it really is just Debian with a few modifications for hardware.