Supervised Setup Ubuntu 20.04 trouble

Hi there,

since my Pi 3’s SD crashed once again. I already had Docker (docker.io & docker compose) together with the Portainer Container installed and running before trying to set up the Supervised Hassio setup.

Running the script worked, all the containers were showing up in portainer and home assistant was accessible.

After a reboot they disappeared though. They don’t show up in portainer and a sudo systemctl start hassio-supervisor.service shows no error but does not bring them back either. Any idea how to fix this?

EDIT: somehow now porainer also stopped working. It feels like I have multiple instances of docker running side by side. I guess I’ll start from scratch. What is the best way to install hassio supervised without breaking a already installed docker setup?

Back up all your yaml files and .storage folder files and start over. Take a look at this to help you out with the install. You can use 20.04.x instead of 18.04.x if you prefer.

Thanks for that link. The issue is that there is no package for Ubuntu Focal (20.04) yet in the Docker Repo, therefore curl -fsSL get.docker.com | sh does not work as of today. I therefore installed it via apt-get install docker.io. Did anyone else install a fresh system based on 20.04 yet?

Any specific reason you need/want to use 20.04.x? You could use 18.04.x and have it all sorted quickly.

Only because it’s the latest LTS version of Ubuntu Server and I prefer starting off with the latest version. As far as i understood the main reason to install docker through docker.com instead of the ubunto repo was that ubuntu had an outdated version. This seems to be fixed, with 20.04 you can even select docker as one of the packages to be installed from the beginning.

2 Likes

Nice, I might give it a test run myself. Other than that, the guide should still work as intended I would assume. Let me know how you go.

For some magical reason it now loads all the hassio containers as well as portainer. That’s a good start I guess :slight_smile: let’s see how porting everything goes :confused:

thanks :slight_smile:

FYI, best practice is to install the full package, rather than just docker.io. Here’s the appropriate command for Ubuntu 20.04:

apt install docker-compose

This installs not only docker.io but also several python libraries

Hi Rob,
I went that route too but then found out compose does not seem to harmonize well (can’t stop Containers run with compose in Portainer) I then went from docker.io and compose to docker-ce (force installed the bionic package).

I guess I should back up everything and start from scratch :slight_smile: which is the preferred one:

A: Only docker-compose via apt get from Ubuntu repo
B: Only docked io via apr get from Ubuntu repo
C:Adding the docker repo and install the bionic package, switch to the focal package once it’s available.

If you are installing server, just select Docker from the Feature Server Snaps page, then skip the command curl -fsSL get.docker.com | sh from the installation instructions.

I just did a test install on a spare machine, and doing it that way worked perfectly.

Alternatively, you could run these in place of the curl command for Docker if you don’t use the above idea.

apt install docker.io
systemctl enable --now docker
usermod -aG docker SOMEUSERNAME

kanga_who, you’re the man! With feature server snaps you likely meant the applications that can be selected during install. I think this is exactly the source of my problem! I selected docker there and then was confused why it’s not showing in dpmg (apt). therefore I installed it via apt. It’s the first time in years that I set up a ubuntu server and spap wasn’t a thing back then. I therefore might have two simultaneous instsances of docker running now, one as a apt package, one as snap. Now i gotta read into the difference and make up my mind which way i prefer…

I gues fixing this on a running system won’t work well? so a reinstall might be inevitable?

I would do it this way. I just did a test install using the snaps method and had issues accessing the HA config directory. I reinstalled and used these commands, and all was normal and I could access the files. Maybe start over with a fresh install.

Thanks again. I removed the snap, reinstalled the Hassio script and moved the settings. Seems to work better already :ok_hand: let’s see if that back and forth remains without issues.

Hey @kanga_who, I was very enthusiastic to find your documentation as it is difficult to easily find ressource to install HA online.Thanks for doing that.
I ran into an issue when getting HA-Supervivised

[email protected]:~# curl -sL "https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh" | bash -s
[Warning] This installer is no longer supported.
[Warning]
[Warning] Home Assistant might work today, tomorrow maybe not.
[Warning]
[Warning] If you want more control over your own system, run
[Warning] Home Assistant as a VM or run Home Assistant Core
[Warning] via a Docker container.
[Warning]
Please typ "not supported" to continue this installation
bash: line 17: syntax error near unexpected token `then'
[email protected]:~#

I cannot continue as it seems there is an error int he installer.sh

Would you have any suggestion?

Thanks

There was an error introduced into the script by the devs. Some people have forked the script and fixed the error. Try this one instead.

curl -sL "https://raw.githubusercontent.com/krdesigns-com/supervised-installer/master/installer.sh" | bash -s

Thanks @kanga_who, this script works better but I’m getting another roadblock on how to set the machine to aarch64:

[email protected]:~# curl -sL "https://raw.githubusercontent.com/krdesigns-com/supervised-installer/master/installer.sh" |bash -s
[Warning] This installer of Home Assistant is for experts only!
[Warning]
[Warning] This method is not supported by the Home Assistant team.
[Warning] You need to solve any issue you run into while installing
[Warning] or updating Home Assistant yourself.
[Warning]
[Warning] If you got this installer from a tutorial, you're probably
[Warning] not expert enough.
[Warning]
[Warning] Press any key to continue or control + c to quit
ModemManager.service disabled enabled
[Warning] ModemManager service is enabled. This might cause issue when using serial devices.
[Error] Please set machine for aarch64

I look in the code to understand who to go around the problem, but I can’t figure out. Your assistance is appreciated.

Thanks for your help Jason!

PS: sorry to hijack this thread with noob questions.

I think @DavidFW1960 forked the script as well, maybe his will work. He might be able to send you the link to his Github for the script.

What machine are you installing on?

Raspberry 4. I looking on resources online, I managed to run it with:

curl -sL "https://raw.githubusercontent.com/krdesigns-com/supervised-installer/master/installer.sh" | bash -s -- -m raspberrypi4

I can now access hass.io web interface. I’ll continue the setup from here.

Thanks for your help!

This part was key :wink: