Supervisor 234 not supported on Raspbian GNU/Linux 10 (buster)? Per error log

Updated to Supervisor 235 and the same error still… What’s wrong with the installation?

So now it’s CRITICAL?

Screenshot from 2020-08-19 11-31-06

What’s next, Hal?

5 Likes

I have the same issue running my HA on Raspbian GNU/Linux 10(buster) , obviously with same error “You are running an unsupported installation”. My noob question is changing OS to Raspbian Buster Lite will not affect the current working HA ? Or installing new OS so HA to run without issue require to take everything from zero ? Sorry if my question sems stupid , I spent a lot o weekends to make it work as it is today , still a lot to learn forward , just a weekend hobby for my and avoiding to pay hundreds of dollars each year to some stupid security company :face_with_hand_over_mouth:, to watch my house.

Don’t lay awake about the ‘unsupported’ message. It simply means you can’t file an issue on github when something goes wrong. You can still get support here on the forum.

1 Like

I’m on Supervisor version 241, i tried to update everything mentioned on this page

on a spare/test raspberry pi 3b+ I even custom built NetworkManager-1.26.2
I’m still getting the “You are running an unsupported installation.” message on the supervisor panel. The only thing left I may not be complying with is the raspbian Buster OS. the link I placed says “Debian Linux Debian 10 aka Buster (no derivatives)” it may be noticing i have “Raspbian GNU/Linux 10 (buster)”

I don’t normally care for such details, but I think this incompatibility is behind my HA freezing every couple of days
sometimes
[paho.mqtt.client] Caught exception in on_message: Event loop is closed
sometimes
[pyvera] Unhandled exception in callback for device #

once it encounters an error it gets stuck. HA gui is down.
i only hope the changes i found here will be enough to my HA stability.
I’ve applied the bottom 2 changes on my main raspberry pi, will wait 1day-1week if stability has improved, and I don’t need to worry about network-manager. the storage-driver on mine defaulted to overlay2 already, the journald is the actual major change.

“log-driver”: “journald”,
“storage-driver”: “overlay2”

You don’t to do anything custom, just install the requirements. Running Supervised on a Pi is unsupported, it doesn’t matter what you do to try and install custom.

Good, just ignore it. It will still run as intended, you just lose “official” support from the Dev team if you have an issue. I have had a Pi3 running as a backup to my main machine for the longest time, no issues with updates etc.

The “unsupported” message has nothing to do with HA/Pi freezing. It’s more likely a database problem, or an issue with your SD card.

Follow this guide for a start to finish on setting up a Pi3/4. As mentioned, I’ve been running this way on a Pi3 for a long time, and recently purchased a Pi4 4gb, and have installed this same method using an SSD as the boot drive. No downtime yet after about 10 days.

99% chance it’s the power supply…

Very true.

I monitor the power supply daily (integration and my own sensor cat /sys/devices/platform/soc/soc:firmware/get_throttled)
no warnings yet. my logs never warn me its the database I use mariadb. I no longer use memory card, i use a bootable solid state drive (my data collection automations killed my memory card before), that’s why i had to switch to raspbian buster to boot from a SSD. I installed supervised HA to get the same perks as hass os but on more stable storage I/O.

but i’m taking the suggestion it could be the db, I do have alot of automation writing to the database, even though my errors are not db, i’d rather have stability, then empty historical graphs at this point.

I performed the following, will cross my fingers for a week.

ha core stop
rm /config/home-assistant_v2.db
ha core start

I could be wrong, but if you are using the MariaDB add-on, the database file isn’t in /config, mine isn’t.

As David suggested, it is also highly likely a PSU issue, especially being that you are running an external SSD.

1 Like

thanks for the tip, that was a residual file before I switched to mariadb. I found mariadb location ssh to the raspbian os directly

/usr/share/hassio/addons/data/core_mariadb/databases

uninstall/install mariadb addon, then reboot HA has recreated the databases folder and contents.

As David suggested, it is also highly likely a PSU issue, especially being that you are running an external SSD.

I hope not, but it will be the next thing i will have to troubleshoot. all my error messages in ha log are not database/power supply related, the errors seem to focus on vera integration and mqtt integration. which is why I was approaching this as a network issue.
before the freezes, I encountered HA mdns repeater issue, HA brought my entire network down, I was upgrading HA frequently, but i was not upgrading Raspbian packages or docker ce. After i upgraded raspbian packages including docker ce,
the mdns repeater (from multicast container) issue went away but HA started having freezes once a week in the beginning, eventually every couple of days.

I’ve been applying HA upgrades and raspbian package updates but no solutions yet.

I’ll wait and see what happens for a week now.

It could be a network issue maybe… latest debian update for me did change the behaviour of my IP address doing odd things… I use IPv6 and the privacy functions changed. I was just reserving the IP address in my router but ended up having to change in debian to a static address. I have also has issues with the dns server and added the cloudflare and google dns into the dns config in HA as well as that was causing what APPEARED to be lockup’s but was actually problems caused by DNS failure. It’s unlikely to be either of these and most likely the power supply but worth investigating.

I just looked at a place I didn’t know about, in Supervisor->System->Log provider (DNS dropdown selected)

i’m seeing these 2 lines repeat over and over, googling it i’ve found someone mentioned about this config file /usr/share/hassio/dns/corefile
you were in that topic as well. have lots of research to do on the error portion.

[INFO] 172.30.32.1:34324 - 25693 “A IN none.local.hass.io. udp 36 false 512” NOERROR - 0 0.000267345s
[ERROR] plugin/errors: 2 none.local.hass.io. A: unreachable backend: no upstream host

fixed the HASSIO dns errors

i edited /usr/share/hassio/dns/hosts

changed this line from

172.30.32.1 homeassistant homeassistant.local.hass.io home-assistant home-assistant.local.hass.io

to

172.30.32.1 homeassistant homeassistant.local.hass.io home-assistant home-assistant.local.hass.io none.local.hass.io

all hassio dns queries now are successfull.

I arrived with this solution from logging in to raspbian buster, ran
ping none.local.hass.io
it returned ip 172.30.32.1, this is why I placed the host none.local.hass.io to
that specific line in /usr/share/hassio/dns/hosts
restarting home assistant the change survives, rebooting the raspberry pi 3b+
the change goes away, i’ll have to setup something to readd the change on hardware reboot.

You should have used ssh and the ha dns command with the servers option to do that. Directly editing those files can lead to problems.

I’m not too familiar with “ha dns” command, or “ha host”, at first glance
i can’t use the below cmd, the dns in my file /usr/share/hassio/dns/corefile looks correct

ha dns options --servers dns://IP_ADDRESS

the below command doesn’t seem to be updating /usr/share/hassio/dns/hosts,
its not clear what ha sub commands will modify /usr/share/hassio/dns/hosts in the way I did it. Googling it hasn’t exactly been helpful.

ha host update

I’ll have to settle with what I’ve done in the short term, until I come across more info on this.

ha dns options --servers dns://1.1.1.1 --servers dns://8.8.8.8

This will add cloudflare and google dns servers permanently!
also

ha dns info

will tell you what servers are set

The first command fixed my issues.

that didn’t resolve my dns issue. I think i have a theory of whats going on. I have a few devices that I have I could not statically assign hostname and ip address because my router says its run out of memory. those 2 devices have no hostname in my network, in nmap -sP (arp scan) they show up with hostname unknown. 1 of those devices is using HA integration vesync. I suspect the unknown hostname is resulting with hostname none in HA and HA is adding the domain suffix .local.hass.io which no dns in my network can resolve.

the cleanest solution is to statically assign in my router those 2 devices with hostname and ip address. I just have to do it from command line, the ASUS router gui is blocking me adding more hosts.

statically assigning those devices didn’t fix the bad dns queries. too bad the dns logs don’t give me more info to narrow down which of my 15 integrations are the culprit.

Found a fix, in this link https://github.com/home-assistant/core/issues/41336
it states the wake_on_lan integration causes dns error when not using the deprecated host: parameter

i put my host: ip parameter back in my configuration.yaml restarted home assistant.

i don’t need the other workaround putting a host entry for none.local.hass.io in file /usr/share/hassio/dns/hosts