Supervisor can't update Home Assistant access token!

Tags: #<Tag:0x00007f738ecc91c0> #<Tag:0x00007f738ecc9080> #<Tag:0x00007f738ecc8f68>

Hope somebody can help. Sinds i upgradend yesterday form 0.107.x to 0.108.x the Supervisor doesn’t work anymore.

My setup:

  • NUC (NUC7i5BNK)
  • Debian 10
  • Home Assistant Supervised on a generic Linux host
  • Supervisor version: 217

Log from the supervisor dockercontainer: (this error keeps on repeating)

ERROR (MainThread) [supervisor.homeassistant] Can't update Home Assistant access token!
ERROR (MainThread) [supervisor.api.proxy] Failed authentication to Home Assistant WebSocket

I have the exact same issue and almost the exact same setup.

The only thing I don’t know is when this was caused, so not sure if it is with regards to the upgrade to 0.108.x.

Did you find a solution?

No not jet, I already tried:

  • Reinstalling the supervisor like this
  • Reboot with an empty config folder.

Both didn’t work.

Sinds this issue is now closed my next attempt will be formatting everything and going the HassOS way.

The issue seems to be related to something with the websockets. I disabled all add-ons and started enabling them again one by one, to make sure it is not a port conflict.

The error shows as soon as I enable the Node-RED add-on. I attempted to use a manually created a long lived access token, but have not yet succeeded in resolving the issue.

Thank you for the feedback!

I hit this issue from google searching for a similar issue:

Mine was that I had removed an empty default_config section from configuration.yaml. Restoring this empty config section fixed this issue for me.

1 Like