Supervisor fails

Tags: #<Tag:0x00007fc415724508>

I’m using HomeAssistant via IoTStack, I can’t see a supervisor link in the navigation menu. So I added it natively as shown in the menu.sh (for IOTStack). I can see it created two services hassio-supervisor.service and hassio-apparmor.service, and it creates a docker container (homeassistant/armv7-hassio-supervisor) which fails with below messages.
I’m pretty new to Home Assistant. How do I get this to work?
Thank you

21-05-01 04:43:00 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/armv7-hassio-audio with tag 17.
21-05-01 04:43:14 CRITICAL (SyncWorker_1) [supervisor.docker.interface] Pulled image homeassistant/armv7-hassio-audio:17 failed on content-trust verification!
21-05-01 04:43:14 WARNING (MainThread) [supervisor.plugins.audio] Error on installing Audio plugin, retrying in 30sec
21-05-01 04:43:44 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image homeassistant/armv7-hassio-audio with tag 17.
21-05-01 04:43:55 CRITICAL (SyncWorker_0) [supervisor.docker.interface] Pulled image homeassistant/armv7-hassio-audio:17 failed on content-trust verification!
21-05-01 04:43:55 WARNING (MainThread) [supervisor.plugins.audio] Error on installing Audio plugin, retrying in 30sec
21-05-01 04:44:25 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/armv7-hassio-audio with tag 17.
21-05-01 04:44:36 CRITICAL (SyncWorker_1) [supervisor.docker.interface] Pulled image homeassistant/armv7-hassio-audio:17 failed on content-trust verification!
21-05-01 04:44:36 WARNING (MainThread) [supervisor.plugins.audio] Error on installing Audio plugin, retrying in 30sec
21-05-01 04:45:06 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image homeassistant/armv7-hassio-audio with tag 17.
21-05-01 04:45:17 CRITICAL (SyncWorker_0) [supervisor.docker.interface] Pulled image homeassistant/armv7-hassio-audio:17 failed on content-trust verification!
21-05-01 04:45:17 WARNING (MainThread) [supervisor.plugins.audio] Error on installing Audio plugin, retrying in 30sec
21-05-01 04:45:47 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/armv7-hassio-audio with tag 17.
21-05-01 04:45:49 ERROR (SyncWorker_1) [supervisor.docker.interface] Can't install homeassistant/armv7-hassio-audio:17 -> 500 Server Error for http+docker://localhost/v1.41/images/create?tag=17&fromImage=homeassistant%2Farmv7-hassio-audio: Internal Server Error ("toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit").
21-05-01 04:45:49 WARNING (MainThread) [supervisor.plugins.audio] Error on installing Audio plugin, retrying in 30sec

Following this I got supervisor working. I can see Home Assistant observer Supervisor:Connected. However there’s still no Supervisor panel in Home Assistant.