Supervisor Intergration

I am puzzled… I have two semi identical home assistant installations running on Virtual Box Virtual Machine Linux Guest Mac OS Host. Home Assistant OS. 11.3 and Coe 2024.1.2. One has a Supervisor Integration that other doesn’t. Not sure what that means nor what the result in. Thoughts?

Thank you but as I noted these are essential identical installations. One has the integration the other doesn’t

Go to Settings > System > Repairs > Overflow menu (3 dots) > System Information.

What is reported for Installation Type on each one of the two installations?

Home Assistant OS.

Is it possible that you, or someone else, used Settings > Devices & Services> Integrations > Add Integrations to install it?

BTW, Supervisor is automatically installed and running on Home Assistant OS and Home Assistant Supervised editions. That just puts a face on it.

I thought I had the answer but I was wrong. I’ll test something and get back to you.

As expected, Supervisor is automatically installed and running on Home Assistant OS and Home Assistant Supervised editions.

Where exactly in the UI are you seeing “Supervisor integration” on one machine but not the other?

its not a big thing. so not worth much. effort. Just curious Everything seems to work

What happens if you go to Settings → Devices & Services → Add integration button → search for “Supervisor” and add it?

Yeah, that’s what I had in the post I subsequently deleted. I tried that and it said it can’t do that and directed me to the configuration file and documentation page for Home Assistant Supervisor.

Me too. Where in the UI are you seeing it?

OK, but if they don’t actually have it maybe it will allow them to install it?

Maybe repair the supervisor from the CLI and reboot (not restart).

Just one other thing. Alphabetically sorted the integration is under “H” for Home Assistant Supervisor, not “S”. Though I doubt this is the issue if they are comparing two systems.

I don’t see it in the list of installed integrations but I know it’s installed and functional (I’m using Home Assistant Supervised).

Scratch that; I’m wrong. It’s in the list. I was looking for “Supervisor” but it’s “Home Assistant Supervisor”.

Doh! :man_facepalming:t3:

You’re right. If “Home Assistant Supervisor” is not shown in the list of installed integrations, @captcurrent should click Add Integrations and install it.

Undeleting my post …

Ok first here is installation with a list of integrations

Right. For the other machine, just follow the instructions here:

ha. a step ahead of you … well actuallyI had tried this earlier and tried again

That’s what it shows when Home Assistant Supervisor integration is already installed (I learned that about 3 minutes ago …)

No that’s the wrong one.

EDIT: unless it is hidden under the message box.

I suggest doing this at the CLI:

ha supervisor repair
ha supervisor reload

Then Reboot. Not restart.

I assume the correct one (Home Assistant Supervisor) was selected but the dialog box is concealing it, leaving only Supervisord peeking above it.

Yeah just came to that conclusion.