Supervisor logs causes high CPU usage and fails to open

Hi all.
Recently discovered such a problem on my HA running on RPi 4GB and SSD disk. When I try to open Supervisor logs via GUI the system hangs and CPU usage goes >40% ,and supervisor logs never opens. Gui gives me error:

Failed to get supervisor logs, Unknown error, see supervisor logs

when trying to check logs via terminal I got:
ha supervisor logs
Get "http://supervisor/supervisor/logs": contex deadline exceeded (client.Timeout exceeded while awaiting headers)

Strangely that other add-on logs I also cannot open, the logs are just blank via GUI. After restart, looks like system tries to recover, and CPU usage is >40% for at least 10 min, and then goes to normal.

All this time HA is really slow at respond (probably because of CPU usage)

What could I do to fix this issue?

Check here, this solution worked for me after all.

1 Like

Thanks. I really dont feel super comfortable tinkering with hassos system. So basically, It could be solved if I bought different adapter what is listed in list of “approved” adapters ?

I dont like this line “(when I add quirks to cmdline.txt, the system doesn’t boot anymore).” :))

Yeah, I know what you mean :). Well, I sorted it out by adding additional “dwc_otg.lpm_enable=0” to cmdline.txt and it booted OK afterwards… If it doesn’t boot, you should easily fix it by attaching the SSD to your PC and revert the changes in cmdline.txt. But if you don’t feel comfortable with it, then it’s maybe really better not to even try messing with it.

Now regarding changing the adapter to the “approved” one - I’m not sure if that is the right solution, because I’m using an approved one, but still had the issue. But I’m not running HAOS, I have Supervised and even that on “Bullseye” Raspbian, which I upgraded from Buster, so this may also affect the function.

oh I see, so basically I can add the cmdline.txt parameters not via ssh to hassos system, but connecting ssd to pc and creating it from there and then try to boot. will try to do that. Great, Thanks :slight_smile:

so your cmdline.txt contain only this ?

usb-storage.quirks=xxx:xxx:u dwc_otg.lpm_enable=0

No, no, I just added it before the existing content, like this:
usb-storage.quirks=174c:55aa:u dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=XXXXXXXXXXXX...this goes on

Also, beware that the content of cmdline.txt MUST be one line only… if you add a linebreak or smthg similar it will refuse to boot.

Great info, thanks.