Supervisor no internet?

Hello guys

I’m trying to update my supervisor from core-2021.4.5 to core-2021.5.0 and when I attempt to do so Supervisor gives me this error:

<sup>21-05-07 04:59:39 INFO (MainThread) [supervisor.host.info] Updating local host information
21-05-07 04:59:39 INFO (MainThread) [supervisor.host.services] Updating service information
21-05-07 04:59:40 INFO (MainThread) [supervisor.host.network] Updating local network information
21-05-07 05:02:52 WARNING (MainThread) [supervisor.jobs] 'HomeAssistantCore.update' blocked from execution, no host internet connection

Right now I access to my home assistant from the outside, using duckdns addon. I also have system monitor the network in and out and data is being sent from/to internet. So yeah, I do have internet…

Any ideas why is this happening?

Thank you

bump. I’m lost on this, can’t make it work

Still need help guys.

I’ve been investigating. I realized that supervisor is giving me not supported version due to network manager. That was a lead. Then I checked HA docs for network manager and I saw a convenience script to fix things. I executed that and terminal gave me that network manager is NOT installed.

Then I’ve been looking how to install it but I have no apt-get installed so I’m kinda in a dead end here.

Having exactly the same problems here - Help!

My homeassistant on my other Debian platform works fine.

But the debian and Hassio OS on Virtualbox both start but fail with supervisor. Tried reinstalling Virtualbox but all still fail.

HA opens but no Addon store and supervisor connection issues in the logs.

My VM’s on Virtualbox are all failing -

21-05-10 12:13:42 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached


'CheckAddonPwned.run_check' blocked from execution, no supervisor internet connection

image

I experienced the same issue. Rebooting the Home Assistant’s host system did the trick.

2 Likes

Didn’t for me unfortunately.
Ended up ditching virtualbox and using HyperV. Was a wise choice.
Far superior in terms of functionality and speed etc.

1 Like

Yup, reboot of the host sorted it for me

Supervisor > System > Reboot Host

2 Likes

Hello everyone! I found myself in this problem too and I can’t solve it!
I also tried to do a new installation from scratch, but unfortunately I can’t even complete the installation because supervisor doesn’t have internet access!
Can anyone help me out?

In my case there were two issues:

  1. IP address of hassio VM was blocked by firewall.
    Diagnostics:
  • ha > login
  • # ping 8.8.8.8 - check that ping goes well.
  • # exit - to leave shell
    Solution: depends on your firewall/gateway soft/hardware.
  1. DNS requests to server were going from 172.17.0.1 IP which obviously internal DNS didn’t like.
    Diagnostics:
  • ha > login
  • # ping 8.8.8.8 - should be alive,
  • # ping yahoo.com - should be allive too.
  • If yahoo ping doesn’t ‘fly’, then check dns with
    # nslookup yahoo.com.
  • # exit - to leave shell
    Solution: fix DNS.

After that update went with flying colors.

I have the same problem after upgrading my firewall. All network settings are the exact same as before upgrading the firewall (same subnet, same server running DNS and DHCP). There are no outgoing firewall rules and no hints in firewall or DNS-logs.
When pinging www.google.com from therminal it gets replies.
When nslookup www.google.com i get this:
Server: 127.0.0.11
Address: 127.0.0.11#53

Name: www.google.com
Address: 142.250.74.100

I have the exact same problem on two different systems (Raspberry PI and NUC) running HA OS installation.

I’m out of ideas, please help!

How did you fixed DNS?

2 Likes

I’m using Armbian based on Ubuntu 20.04.4 LTS.
To fix DNS I added DNS servers to /etc/systemd/resolved.conf. I have two own DNS servers, if you want you can specify nearest appropriate server (for example provider’s DNS or 8.8.8.8, 1.1.1.1, etc.)

...
[Resolve]
DNS=192.168.1.1
FallbackDNS=192.168.1.2
...

Then
systemctl restart systemd-resolved

had the same issue, a few moments ago. I changed the HA DNS (which was my router IP) to the Google DNS (8.8.8.8). That fixed my problem.