Supervisor not starting Help

Hi all
Running HA supervised on Ubuntu 20.04
Latest HA build, with
one morning i got my HA not opening any addons (node red, visual studio)
so i rebooted host, and supervisor is not starting, HA is not starting.
i get this error on Supervisor

11:25:51 ERROR (MainThread) [asyncio] Unclosed client session
client_session: <aiohttp.client.ClientSession object at 0x7f5f193a3c10>

So Supervisor loads every minute in portainer and shut downs due to error
I can Manualy load Homeassistant container but it is plane without any addons

You’re probably aware but this is an unsupported installation method. Supervised installs are only supported on vanilla debian, no derivatives (like Ubuntu or Raspbian). Therefore you should expect strange and unannounced breaking changes at times because no one is testing that it works on your setup prior to release.

Squinting at the screenshot it sounds like a Cgroup error. But not really sure, Ubuntu is pretty different from Debian.

@denveronly I have the same setup and issue, please let me know if you solve it.

There is a closed issue in github related to the problem where Frenck confirmed its indeed related to croup.
Proposed solution, to my understanding, is to rerun the installation script with the latest version. Not sure if it works only for Debian though. I’m currently away from my installation so I cannot investigate atm.

Github: Latest Update 2022.06.0 Not Starting · Issue #3692 · home-assistant/supervisor · GitHub

Ive found the reason what was the cause
So i made following steps
Deleted supervisor container and installed it once again - still no luck

Then i checked my docker version wich was 19.04 as if not mistaken. It was old but supported
Ive updated docker version and all got working like nothing happened

That was kind a wierd because there should be an error that docker version is bad, but it is what it is

Great that you solved it!
So which version of docker do you run now?

I think 19.04 is the latest in apt?