Supervisor shows blank page

Hello,

About a month ago I did an update of Home Assistant.
Since then I have some blank pages.
Supervisor, File Editor, Node Red, Snapshots and Terminal show nothing.
The url is changing, but the browser shows nothing.

I have no error or popup.

Does anyone know how this happend?

I’m using a RaspBerry Pi 3 with an SD-card.
I’ve installed HACS with a few integrations.
Version = Home Assistant 0.112.4
supervisor: 225

Try another browser?

I have a black page for supervisor a while via a slow Internet connection and via nabu case as well.

Hi,
I just tried Firefox and IE.
Firefox has the same problem, IE is showing nothing, not even the landingpage.

@lisa

Did you find a solution? I just started having same issue.

Thanks

Hi @OreoP,

No, still the same.
I tried to set everything in comments, removed all the integrations in HACS but I still have the issue :neutral_face:

Do you only have a blank page on Supervisor?
Or also on other tabs?

Blank on supervisor, file editor, node red.

Everything was working fine till yesterday…this morning the issues started.

I wasn’t using my HomeAssistant for a few months.
Then a month ago I was configuring some things and did some updates .
After the updates I noticed the issue…

Did you change something yesterday?

Just added some new devices…but nothing out of the ordinary.

I run HA on a VM. Shut down everything, restarted the computer and VM and everything came back. However, one thing I did notice is that I had a notification for an update.( HA 0.114.0). Immediately after the update, the same issue - blank screens on Supervisor, File Editor and Node Red.

Shutdown everything and restarted the computer and VM - and the problem was gone…my guess is as good as yours but it sure points to updates.

I ended up formatting my SD card and it was corrupted after that.
Bought a new SD card and restored from a backup.
Everything is running again!

I want to share my experience with hassio and the “supervisor blank” issue. In my case is happened about every 4 hours, and also addons in the interface were not responding (as an example also “file editor” on sidebar showed a blank page).
I am running hassio on Raspberry 4 with 4MB and up-to-date software as today. I also have external Crucial 120GB BX500 SSD drive (no way to make it work well on USB3 ports, many low level block errors on console - its fine on the USB2 port).

After configuring 100 entities, automations, several integrations, addons, I began to have the issue regularily after about 4 hour from boot: supervisor blank, many things not working (for example restful commands). I dont want to go into details.
I issued a “ha core rebuild” and ha host restart" and every time all restarted ok.

After trying to read lots of posts in the forum, unable to find a solution, I began to remove blocks of entities, integrations, and addons, removing them step by step and verifying stability at every step, issuing a core rebuild and a restart.
After several tries (problem arising regularily after about 4 hours), I finally deactivated GOOGLE CAST integration and KODI LibreELEC integration: everything resumed flawlessly. Finally some fresh air !! I was about to give no more time to hassio.

At this point I reconfigured all entities, addons and integrations, all was ok (still working well after 10 days).

I dont need chromecast and kodi integrations, they were installed automatically, so I will let them DISABLED.

Just to identify precisely the problem, I have now reactivated the KODI integration, we’ll see if the system breaks again after some hours.

OK ended my tests. Activating KODI integration hassio breaks again. After deactivating it and restarting, and all was OK. After 1 day have reactivated Chromecast integration, and all is well.

So finally the problem is the KODI INTEGRATION - I hope that someone reads my experience and fixes that, maybe a memory leak

Thanks for this tip. I had the same problem (blank hassio page when I tried to go on the supervisor link) and disabling the kodi integration solved my problem. I would have never guessed it was that…

I have the same issue. Supervisor has a blank page. Add-ons in sidebar stops working as well. I notice the issue because my notifications stops working. Issuing the ha host reboot command solves it temporarily. I am running HassOS on a NUC and also have the Kodi integration. I was running the 2021.5 beta versions and thought it was just a bug. After updating to 2021.5 it was stable for a couple of days and then started again.

I had a network issues around the time this started and I think my Kodi got a new IP Address in the process. I checked my Kodi Integration and it lists the current IP address of Kodi. I have disabled it now to see if it resolves the issue completely.

EDIT: It has indeed resolved it. 2 months down the line and still no issues.

I had the same issue happen overnight to me, seeing a blank screen when accessing the Supervisor, Node Red etc. The issue seems to affect any of the add ons pinned to the side panel.

The issue appeared to coincide with installing Kodi on a fresh Ubuntu install I did last night.

After reading this thread, I removed the Kodi integration and I no longer get a blank screen.

Hi guys.
I found another solution. Go to Terminal tab and enter “ha supervisor repair”. After couple of minutes I got my Supervisor tab back.
Hope this helps.