Supervisor - snapshot restore issues

I’ve tried restoring a snapshot onto new server and having lots of problems getting several to start. I’ve even tried removing the addons and re-adding. my snapshots are all hassio latest builds 107.7 (214 and 3.12). Several of the addon’s show the same error as what i’ve included for node-red:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] executing... 
 Add-on: Node-RED
 Flow-based programming for the Internet of Things
 Add-on version: 6.1.4
 There is an update available for this add-on!
 Latest add-on version: null
 Please consider upgrading as soon as possible.
 System: HassOS 3.12  (amd64 / qemux86-64)
 Home Assistant Core: 0.107.7
 Home Assistant Supervisor: 214
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[09:21:16] INFO: Password is NOT in the Have I Been Pwned database! Nice!
[09:21:19] INFO: Password is NOT in the Have I Been Pwned database! Nice!
patching file nodes/ui_base.html
Hunk #1 succeeded at 1243 (offset 712 lines).
    slice: (buf, start, end) => buf.utf8Slice(start, end),
RangeError: Index out of range
    at Object.slice (buffer.js:585:37)
    at Buffer.toString (buffer.js:782:14)
    at Object.readFileSync (fs.js:386:41)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:990:22)
    at Module.load (internal/modules/cjs/loader.js:811:32)
    at Function.Module._load (internal/modules/cjs/loader.js:723:14)
    at Function.Module.runMain (internal/modules/cjs/loader.js:1043:10)
    at internal/main/run_main_module.js:17:11 {
  code: 'ERR_OUT_OF_RANGE'
[09:21:23] FATAL: Failed un-installing conflicting packages
[cont-init.d] exited 1.

I’ve also noticed that it gives me a warning that protection mode is disabled but doesn’t display the slider to change.

Appreciate any help on where to go.