Supervisor suddenly not loading

I ran into problem again which is about the Supervisor as a whole.


How to solve this? I’ve been trying to reboot and it didn’t work (using Restart System on the HA didn’t do anything too). I’ve been re-installing HA Supervised (though overwriting the current existing HA files) with the steps given and it didn’t change either (I’ve looked into similar problems of Supervisor like this, but most of them seems to be the one in HASSIO era, which has stopped). Or is the problem Internet connection related?

1 Like

I have the same issue after update OS 6.3 and Core 2021.9.3

System health info:

System Health

error: failed to load: unknown

GitHub API: ok
Github API Calls Remaining: 4892
Installed Version: 1.15.2
Stage: running
Available Repositories: 880
Installed Repositories: 15

can_reach_server: ok
remaining_requests: 18

logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: ok

error: failed to load: unknown

dashboards: 3
resources: 6
views: 13
mode: storage

I’ve execute over SSH ha core rebuild an seem that the Core update was corrupted because after run this command the core has been downgraded to core-2021.9.2. More later I will to try to upgrade again.

Sorry can you give me complete methods to solve this (if you’re already done) or you just simply do that?

  1. Connect to your HassIO instance: ssh root@YOUR_HASSIO_IP -p 2222
  2. Execute this command ha core rebuild
  3. Reload your browser

At this point in Supervisor tab you can show the 2021.9.3 update again and apply normally.

I only do these steps and now my HA is running normally.

If you are using the Home Assistant Supervised edition and you have not recently installed os-agent then you may experience the kind of problems you have described.

The need to manually install os-agent was announced in this blog post posted August 24th, specifically the last section about OS Agent.

Oh right, actually the step is just that simple. It works now, thank you.

It’s the custom of this community to mark the post that provides the solution with the Solution tag (not your own post that only confirms what someone else suggested actually works). For more information, refer to guideline 21 in the FAQ.

As it apparently requires Debian 11, can I update Debian 11 directly on my current OS, or I have to start over and install Debian 11?

The command sudo dpkg -i os-agent_1.0.0_linux_x86_64.deb doesn’t seem to work.

My OS is currently Raspberry Pi Operating System ARM64 BETA release a (Debian ARM64 with Raspberry Pi Desktop).

of cause not. If using aarch64 you have to install that version, not the amd64 version