Support for Flexit Nordic S4 (IP/Modbus)

It seems original author is not working on this integration anymore according to the PR. I also have the Flexit Nordic unit and I would like to get this done as it’s also useful for me. So I forked piotrbulinski PR and continued the work. I already added somewhat working fan speed adjustment. I opened a WIP PR here: Flexit bacnet integration by Kazhuu · Pull Request #98663 · home-assistant/core · GitHub.

@Kazhuu That’s great, looking forward to it!

Maybe we have progress on this?

Hey all.

I can happily inform you guys that the PR I opened (based on Piotrs original work and python library) was merged today. We will probably have support for Flexit in January!

Merry Christmas :slight_smile:

I have also talked to @Kazhuu on continued development of the integration (i.e. discovery, more modes and sensors and more)

Cheers

/Lellky

2 Likes

Hey,

I’m waiting like a child on christmas eve for this integration :smiley:
Just curious, can we still expect this integration to be availible this month?

1 Like

Yes it is there! Thanks a lot to all contributors.

Question, what integrations automation’s do you have for your Flexit Nordic (or other supported models if any)?
For now when the target temperature of the main heater changes, the target temperature on my Flexit automatically changes as well.

Next thing I want to do is to set the Flexit to off when the outside temperature is too low (<-15C or so) because the heat exchanger is not working the anymore. If we have access to all temperature sensors in the Flexit unit, we can easily see when this happens. So that would be my feature request; add more sensors.

Hello,

How I can see it? I can’t find it in integrations, only cloud version.

I use:

  • Core2024.1.3
  • Supervisor2023.12.0
  • Operating System11.4

Ed

Turning the device completely off is not advised by Flexit due to the risk of condensation in the pipes and frozen rotary heat exchangers. This can be very costly, and the possibility to easy turn off the unit will probably be removed from the integration UI.

What you should do instead is to set it in Away mode so that the fans are still spinning, but at a much lover rpm.

Sensors for outside temperature, room temperature, fan speed and many more will come in the future.

Go here Flexit Nordic (BACnet) - Home Assistant and click the Add Integration-button.

This integration does not support configuration via the UI. If you followed this link from the Home Assistant website, make sure you run the latest version of Home Assistant.

Are you running the latest version of Home Assistant?

Today it was -15°C where I live and my heat exchanger was running at 81% efficiency. Are you sure it will stop working below -15°C

Device Name: Flexit Nordic
Serial Number: 800130-002967
Device Model: S4 RER
Outside air temp.: -14.4 °C
Supply air temp.: 19.2 °C
Extract air temp.: 19.6 °C
Exhaust air temp.: -7.9 °C
Room air temp.: 14.0 °C
Room 1 humidity: 0.0%
Room 2 humidity: 0.0%
Room 3 humidity: 0.0%
Comfort button state: True
Operation mode: 3
Ventilation mode: 3
Air temp. setpoint Away: 18.0 °C
Air temp. setpoint Home: 20.0 °C
Fireplace duration remaining: 10 minutes
Rapid ventilation duration remaining: 10 minutes
Supply air fan control signal: 74%
Supply air fan RPM: 2746
Exhaust air fan control signal: 70%
Exhaust air fan RPM: 2554
Electric heater enabled: True
Electric heater nominal power: 0.800000011920929 kW
Electric heater power consumption: 0.44214844703674316 kW
Fan setpoint - supply air Home: 74%
Fan setpoint - supply air Away: 42%
Fan setpoint - supply air High: 100%
Fan setpoint - supply air Cooker: 50%
Fan setpoint - supply air Fireplace: 90%
Fan setpoint - extract air Home: 70%
Fan setpoint - extract air Away: 40%
Fan setpoint - extract air High: 100%
Fan setpoint - extract air Cooker: 50%
Fan setpoint - extract air Fireplace: 50%
Air filter operating time: 8760.0 hours
Air filter exchange interval: 8784.0 days
Air filter polluted: False
Heat-exchanger efficiency: 81% <================ HERE
Heat-exchanger speed: 100%
  • Core2024.1.3
  • Supervisor2023.12.1
  • Operating System11.4

So it should work, it was added here: 2024.1: Happy automating! - Home Assistant

Do you have a network cable attached to you Flexit unit and know the ip-adress? If so, you should go to Settings → Devices and Services → Add Integration Button and then search for Flexit, click on Flexit and then click on Flexit Nordic (BACnet). Enter the IP-adress and Device (usually 2) and click Submit.

Hello,

So I have the latest version, but when I try to search for Integration, I cant find.

image

Ed

Almost there!

Just click on Flexit. Then you will see the two Flexit integrations :smiley:

Hehe, NO, but I solve the problem.

I uninstall Flexit HACS plugin, only then I found this one. thanks.

Ed

1 Like

Thanks for the info, I was informed by the installer to switch off the heatexchanger when it was over -15C, that was new info he got. But a frozen heat exchanger does not sound good.

looking forward for the future releases!

When it is -15C it was still working but at around -18C, -19C the temperature blown into the house was only a few degrees, so then not was clearly not working anymore.

by the way how do you get all that info out of your unit?

With the python library that the integration use for reading and writing data: GitHub - piotrbulinski/flexit_bacnet: Client BACnet library for Flexit Nordic series of air handling units.

All that data will eventually (hopefully) come into Home Assistant as sensors.

1 Like