Support for Midea A/C

Ok, you’re right, everything is really here, but it took a lot of time to figure out such a simple thing. The submission of information is very upsetting, but glad to have it, thanks to Aceindy
Works without TTL converter (WeMos D 1) and is updated via OTA.
Go to Supervisor-> ESPhome-> Configuration
in the line esphome_version add dudanov: midea-climate-support, Save, the plugin will ask for a restart.
Next, go to the ESPhome tab and, as usual, create a configuration with the code specified at the beginning of the branch. compile the file and flash the ESP
It’s all. Why information on cmd python, docker was given. I had to install Python, I assure most people using HA this is not a standard program. I had to install Git. And all this was unnecessary.

1 Like

Probably because you used a WeMos D1, which has more RAM than the ESP01 I used.
Hence OTA works, and installing Python/Git is not needed…
But I did not have a WeMosD1 and ended up with

ERROR Error binary size: Error: ESP does not have enough space to store OTA file. Please try flashing a minimal firmware (remove everything except ota)

So I needed to find another way to load the binary in the ESP :wink:

As said before, there are many ways to flash ESP.
And also, yes this is still in Beta, so we just figure things out as we go…

Anyway…happy it works :+1:

Might aswell ask you a question then :stuck_out_tongue: You say you use a Wemos D1, do you use this with a logic level shifter? Someone else in this thread who uses a Wemos said he needed a level shifter. I’m planning on building two more advanced dongles with extra IR support and maybe RF based on a Wemos.

That exactly proves my point. If you don’t know why, chances are high you don’t know how. Let’s just assume, something goes wrong with this. Did you do a backup before you changed your ESPHome version to the one dudanov is offering? Did you do a backup of HA before doing all this?

I’m quite sure you didn’t. :slight_smile: And now let’s assume something has gone wrong. The only people who could really help will most likely be the developers of this intergation. So their time goes into helping others, where it should/could go into developing the integration. You get the idea. :slight_smile:

Besides the fact, that I personally wouldn’t want to be responsible for any damage you might do to your climate unit, if you pump the wrong voltage into it. What if this thing blows? I can only imagine what outcry that would be. :slight_smile:

But let me just say, I’m glad it worked for you, and I hope it works flawlessly for you in the future. :slight_smile: :slight_smile: :slight_smile: If you could report back any problems, that would be helpful to the developers as well.

@nvschilleman You should use a level shifter, as the Voltage seems to be important. :wink: As far as I can see, the D1 sends with 3.3V, whereas the A/C seems to need 5V (or was it vice versa?). Can’t you measure it with the original dongle? I would use a level shifter, before you damage either the D1 or the A/C.

1 Like

nvschilleman As I wrote above, I use the WeMos D1 Rx and Tx pins. They are limited to 6V, then they are simply limited. How NodeMCUs from other manufacturers work, I can’t say, need to read the documentation

paddy0174 daily backup https://github.com/samccauley/addon-hassiogooglebackup#readme

Yey…it is finally merged in dev…


Won’t be long now until it is released :smile:

3 Likes

Hey @aceindy,
Just to let you know that with the latest DEV ESPHome update, I could update the ESP01 by OTA without issues (with the previous version I had the same exact issue you have).
You may want to give it a shot :slight_smile:

Cheers

So I’ve got the dev version of ESPHome installed but still getting this:

image

And I’m getting this when using the python method:

image

All my ESP-01’s flash OTA without problems, maybe erasing Them completely and flashing Them over UART once Will fix your issue, that’s what I did.

So what is the recommended Home Assistant ESPHome addon to use now?

Is it still the dev version?

I have tried it with and without the custom version entry in configuration with no changes in the outcome.

The “midea_ac” component is still not being recognized.

Would someone mind elaborating on what they are currently using with success?

Using this for the custom version just worked for me…

dudanov:midea-climate-support-wo-integrity-check

how did you get yours to work mine only shows TX in the logs,
im using a wemos D1 though

i think you have to use this repository:

that repository came out after nvschilleman had reported similar issues.

Where? here:

yea saw the same thing, I have the repo installed witch made it show up in HA and with a connect status, for the D1 mini.
How every wen I check the logs in ESPhome i only get a TX control in the log, as ican not control the unit

Blockquote
[21:21:52][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 02 40 41 86 00 7F 7F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 66 C2
[21:21:53][D][midea_ac:050]: TX: control
[21:21:53][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 02 40 41 86 00 7F 7F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 66 C2
[21:21:54][D][midea_ac:050]: TX: control
[21:21:54][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 02 40 41 86 00 7F 7F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 66 C2

witch puzzles me a bit

Do you use a level shifter on the TX/RX pins of the Wemos?

no i do not wasn’t aware i need one, any suggestions for one ?

Well it appears some units need it, and some do not. I thought @Ice_Juice got his Wemos working without, but @vilord 's units did not respond to commands without a level shifter.

I currently run all my AC’s on ESP-01’s but I have some level shifters laying around to build two Wemos based dongles.

Reading your name I assume you are Dutch like me so sending you a link to a Dutch site won’t be a problem, I have these: https://www.bitsandparts.nl/Logic-Level-converter-shifter-I2C-5-3V-p1107480?gclid=CjwKCAiAhbeCBhBcEiwAkv2cY0_TNgwzuxXaqkmLt-kd9jMap1ym1iLVBXHYMvAB_OS6QxACF5eY1xoCl9UQAvD_BwE

I got the same thing, TX only in the logs until I used a level shifter to bring the 3.3v rx/tx up to 5v

just order them, did you connect via the usb port then ? wen you installed the shifter ?

indeed i aim ^^ just order them ^^