Support for Velbus Home Automation


#22

They seem to have mentioned it in the changelog… Too bad, homeassistant looked very promising.


#23

Currently we support:

  • all relays
  • all glass panels (everything except the thermostats, this is WIP)
  • all modules with a temperature sensor in it (except the weather station)
  • vmb6in
  • vmb7in including the counters (in the next week this will be in)
  • vmb*pbn modules

if you need something else let me know, we can add it


#24

Also this is all auto-dicoverd, so no config needed (except for the port)


#25

Vmbdmi-r
And the thermostat function are the most important


#26

I don’t have any vmbdmi devices to tests, so implementing this can be hard.

The thermostats are next on my todo list (once the vmb7in is finished)


#27

Tell me what you need to make this happen


#28

BTW is there a way to connect to a velserv server? Instead of using the port using a network address on which the velserv runs? This adds flexibility in using velbus by other devices.


#29

yes (i’m using it this way)

velbus:
port: ‘127.0.0.1:3788’

for the vmbdmi, what messages should be implemented to get this working? (vmbdmi protocol

  • dimmer switch status
  • dimmer slider status
  • dimmer status
  • Set dim value

anything else?


#30

yes thats right. I have a vpn ready with velserv if you want


#31

Ok, once my counters are in, i’ll start working on the dimmers first then


#32

I tried to connect an ip velserv server but that doesnt seem to work. I get an error with the velbus configuration. The syntax in the config file is correct
velbus:
port = ‘192.168.1.7:6000’


#33

euhm, it is velbus: not =


#34

also make sure your python-velbus is a recent version


#35

yes its : got it
strange thing is I have the same issue now with zwave…

Can this be a syntax error or a copy paste error?

Where do I get the most recent velbus python file


#36

are you running the dev branch? or the release version?


#37

Tried both. Where can i get the latest python velbus and where do i replace it?


#38

latest dev branch has latest python-velbus, but make sure to rerun setup.py from HA after updating



#39

Hi Cereal2nd,
For Linux devices it doesn’t work starting from 0.7x
The validation gives no error, but after restart home assistant reports it can’t set up Velbus component.

velbus:
port: ‘/dev/ttyACM0’

Doesn’t work anymore. As the velserv is much more expensive than the VMBUSB, i can’t easilly switch to that.
Any idea what might be the problem?


#40

Hi BTC, probably it is just a change of interface that is causing you trouble. Have you checked that ACM0 is still valid for your setup/boot? As far as I know the USB connection should still work as before.

Also velserv is not the expensive solution with an extra component but available for free, check: https://github.com/StefCoene/velserver


#41

I use this one

It a verry simple c-interface and does not have all the extra stuff like the one from StefCoene