Suppress errors from Shelly Lamps that are not always powered

I have a few Shelly Wifi lamps that aren’t always powered. 3 out of the 20 connected. I have a script that when these lamps turn on they are set to a certain brightness depending on time of day, this all works fine. But since HA see’s the lamps as offline sometimes I get flooded with errors like this:

Home Assistant is not receiving push updates from the Shelly device Shelly Vintage - Leeshoek with IP address (removed). Check the CoIoT configuration in the web panel of the device and your network configuration.

Ignoring them only hides the current error and 10 minutes later another one pops up.

Can I disable this for these 3?