↔️ Swipe Navigation

*Edit Nvm. I just looked into adding sub dashboards and I found out that you can add more dashboards in the same dashboard which works perfect with the swiping.
I thought the dashboards were supposed to swipe between the dashboards on the sidebar.
The way its working makes total sense. Simply being derpy, leaving this here in case someone else makes a similar mistake.

This is what I get for being new to home assistant. Thanks for the amazing plugin!

I’ve just installed this through HACS but I can’t seem to get it working on my phone.
I’ve enabled logging to try and figure out whats going on but I’m a bit clueless as to where the logging takes place? It’s not showing up in my home-assistant.log
My dashboard contains:

title: Overview
swipe_nav:
  wrap: true
  animate: none
  prevent_default: true
  swipe_amount: 15
  enable: true
  logger_level: verbose
views: 
etc

Also tried it with no config but same effect.

It shows up under dashboard resources, I’m using it in combination with: auto-entities, card-mod, mushroom and mini-graph-card-bundle.
I’ve tried rebooting the HAS mobile app a few times and looking at it through chrome/firefox but no swiping options are appearing.
Looking at it through my desktop browser I can see the script is active:

↔️ Swipe navigation ↔️ - v1.11.1 swipe-navigation.js:1:42978
↔️ Swipe navigation: [I] New configuration loaded. swipe-navigation.js:1:43883
↔️ Swipe navigation: [D] Config is identical. swipe-navigation.js:1:43883
↔️ Swipe navigation: [D] Object refreshed: "div". swipe-navigation.js:1:43883
↔️ Swipe navigation: [D] Initializing SwipeManger... swipe-navigation.js:1:43883

My HAS is on 2023.5.3

Any clues?

Hi, not work on latest version of HA

This is mega, love all the animations when sliding between. Thanks!

Have some mini-graph-cards though and am unable to view points on a graph (on a touch device), as the dashboard wants to slide tabs

It works, trust me.

You can propose swipe exceptions. Just post an issue on Github stating the plugin you are using. If you prefer to post here, it’s ok, I can open the issue for you.

@Zanna_37: thanks for picking this up! :bowing_man:

Had used it before, lost track of it since I did a fresh install a while ago but today finally took the time to add it to my touch systems.

1 Like

Swiping using the mouse is now possibile with v1.13.0.

1 Like

Hi there. Since I found this swipe feature it improved by miles the usability of the home assistant in my phone. Unfortunately today I updated HA to:
Supervisor 2023.10.0
Operating System 10.5
Interface: 20231002.0 - latest
After the update the swipe feature doesn’t work anymore :pensive:
I updated the hass-swipe-navigation to version 1.13.1 but it still doesn’t work!
Does anyone has a suggestion in how can I put the swipe feature working again ?

No answers :sob:
But one month later and after updating to versions:
Supervisor 2023.11.1 and Operating System 11.1
It started to work fine again :tada:

To be honest it never stopped working. I have automated tests that check every released version of HA. On top, nobody else ever complained about that, so it must have been an issue on your side.

Hello Zanna_37, I am new to HA and I am trying to use the swipe card in my dashboards. I downloaded it through HACS but when I go to add a card, I don’t see the Custom Swipe Card as an option.

I do see that swipe-navigation.js is at /www/hass-swipe-navigation/ and also the relevant resource is there under Dashboard Resources.

I must be doing something wrong. Please advise. Thanx

If you installed it, just use it.
No card to add, nothing. Just swipe. =)

Hi, welcome to the forum.

You need multiple views in the same dashboard and the swipe motion might be bigger then you are used.
Also, at least here, it doesn’t work on my desktop.

HTH

Well, this is embarrassing…made a rookie mistake…

Wanted to try the custom swipe card so “swipe” was top of mind… Ended up downloading “swipe navigation” by mistake and was lost when I couldn’t find the card…

The moment I read both replies (Zanna_37 & Nick4), I realized my mistake… and now I do like swipe navigation AND have downloaded the swipe card as well…

So all is good (for) now…!

Thank you both for the quick response… much appreciated

2 Likes

Just installed this, and while it works fine in chrome on windows, I just can’t get it to work on a Samsung galaxy tab A8, neither in the app nor Chrome. It works fine on iphone however. Any ideas…? Just nothing happens

I am fairly new to Home Assistant but well on my way to creating multiple dashboards.
I came across this topic with the addon to swipe between all dashboards. That’s something I missed with my Homey app.
I installed the addon as explained in the video and added the code to all my dashboards as explained.

Unfortunately, I am unable to swipe on my Samsung S23 Android phone.
I have rewatched the video several times to see if I had missed something or did something wrong, but that doesn’t seem to be the case.

I did manage to get the swipe card working, which is also explained in this video.

Can anyone tell me why it’s not working?

I used this code:
"title: Thuis
swipe_nav:
enable: true
wrap: true
animate: null
prevent_default: false
swipe_amount: 30
views:

  • path: default_view
    etc."

Home Assistant version

  • Core 2024.5.3
  • Frontend 20240501.1

Running on Synology NAS Docker.

Thanks.

Hi, as you can see from the ’ How to help us help you - or How to ask a good question topic there is a section on how to format your code properly.

1 Like

I have got it working already. I needed to create multiple views in my dashboard instead of having multiple dashboards.

Thanks.

1 Like

It’s strange, in my laptop i can swipe using my mouse just fine, but on my raspi official touchscreen and my phone both don’t work. I have the latest off all the software. Also have the Chromium back/forth history turned off. Downloaded 1.13.3 today.

Funny enough, I tried it this morning and now it works! Only thing is that my card has the background image, not the view itself so when I’m swiping, the background is white, and then goes back to the background image. How can I make that background black?