Switch Bot BT with Shelly+


I have a Switchbot Lock. and would like to connect it to HA via BT.

My BT proxy with Shelly Plus also works. And when I look at the log of the ShellyIntegration, I also find the MAC from the SB Lock (but name is null).
The integration always says it can’t find any devices nearby. Unfortunately, I can’t enter a MAC address either.

Unfortunately it won’t work. The Shelly’s only allow for passive BT connections (like a temp sensor that’s just blasting out it’s data) but an active connection is required.

I was bummed by this for the exact same reason; I also tried putting ESPHome on it, but it wouldn’t boot with BT Proxy enabled. Hopefully Shelly enables this in the future…

It works fine with a normal ESP BT Proxy device though.

Ah ok, I understand! Thank you for the clarification!

Too bad, but now at least I know why.

Best regards