Switchbot - Add support for Outdoor Meter

Just as a tip. I use Thermal Comfort to calculate those values and you can use temp and humidity from the Switchbot Sensor as Input sensors.

1 Like

With Bluetooth, automatically they become visible

With Bluetooth, they become “discoverable”. Something has to be added to read and interpret this. Where and how was it added to make this possible?

Not seeing mine in HA yet. Perhaps it’s out of range. Although, it’s close to a Shelly gen 2 relay that acts as a Bluetooth proxy for another Switchbot meter I have close to where the outdoor one is hanging.

If the sensor is within bluetooth range and not auto discovered you can try to add the sensor just via the Switchbot Integration. If the sensor is available it should be discovered.

Auto Discovery worked on my side.

Maybe you ignored it before because before the HA update, the outdoor meters where visible as plugs :slight_smile: un-ignore them and it’s fixed

Thanks for this hint. I was having the same problem (Switchbot Indoor/Outdoor Thermometer/Hygrometer was showing up as a Switchbot Plug in Home Assistant), and my Home Assistant version was 2023.03.

Now I upgraded Home Assistant to 2023.07.02 and the devices were immediately recognized as the correct ones (WoIOSensorTH).

I have un-ignored the previously ignored plug (which was the Outdoor Meter) however, it has not come back as discoverable.

I have restarted my Home Assistant and also reconnected the meter to my Hub Mini. 3 days in and still has not been rediscovered.

Any help would be great

HA Version:
Home Assistant 2023.5.3
Supervisor 2023.08.3
Operating System 10.5
Frontend 20230503.3 - latest

Do you have passive scanning enabled for Bluetooth? I had to disable it for my outdoor meter to be discovered.

Also, you may need to update to a more current version of HA.

No idea how to do that when using ESPHome Bluetooth.

I use an ESPHome bluetooth proxy as well, but this is in the bluetooth integration, not ESPHome.
Click Configure, then uncheck Passive Scanning and submit.


I think this might due to you having built in bluetooth on the hardware you are using or a seperate dongle as my ESPHome bluetooth does not register for the bluetooth integration mate.

Ah, I understand now.

Looks like it can be set in the configuration, though it is defaulted to false.

Well this doesn’t help solve anything but I appreciate the info

You may need to upgrade to a more current version HA then.