Switchbot, Bluetooth Proxies and release 2022.10.1

With 2022.10.1I am really happy all my Switchbot devices are now found by Home Assistant, and the ones that where found before now also can be controlled. But I noticed some odd behavior that I was curious if others also experience.

Before this release I integrated most Switchbot devices using the ESP32 solution (found on this blog) except one device. The Humidity/Temperature sensor. That one always worked perfectly directly in Home Assistant.

As a test I’ve now switched everything over to the native Home Assistant Integration for Switchbot for 4 curtains and one bot. And kept the already native integrated Humidity Sensor as is. I also have one BlueTooth Proxy.

  • The curtains and bot now work, most of the time but not as reliable as on the ESP32 solution
  • The Humidity Sensor, that always was native, also has become unreliable?!

And that last one surprises me. It worked perfectly native before this release. I am curious if anyone has had any similar issues and that it may be that the proxy -while helping the other devices- made the sensor less dependable?

I noticed telling Home Assistant to reboot fixes everything. But this seems to be a thing to do once a day at least.

I’m considering the following solutions:

  • change my dashboards & automations back to using the entities exposed through the ESP32 solution and adding my humidity sensor there also.
  • Adding more BlueTooth proxies? Currently the situation is: Home Assistant is located on the second floor, the Humidity Sensor (previously always found, now disconnecting), two curtains (found before but not responsive before this release) and Switchbot bot (never found) on the 1rst floor, 2 curtains (found and always disconnecting before) on the ground floor. The Proxy I currently added is also on the ground floor, but near the stairs and as such also very close to the bot and humidity sensor on the 1rst floor.
1 Like

Can I ask how you added these to home assistant? I have 1 Shelly with Bluetooth enabled in active mode, but when I try and add the switchbot it doesn’t see it.