Switchbot Bot not being found via BT or BT proxy

Hi, i have some issues with integrating a Switchbot Bot directly via Bluetooth.

Until now i only had 1 Switchbot Bot and used it via SwitchBot-MQTT-BLE-ESP32 ( GitHub - devWaves/SwitchBot-MQTT-BLE-ESP32: Allows for multiple SwitchBot bots and curtains to be controlled via MQTT sent to ESP32. ESP32 will send BLE commands to switchbots and return MQTT responses to the broker. Also supports Temperature, Motion, Contact sensors ) - and that worked perfectly fine!

Now i got a Switchbot Lock and found that it doesn’t work with that MQTT bridge, so i thought i might try the bluetooth proxy ( ESPHome Bluetooth Proxy ) on my esp32, and that also worked perfectly fine - the problem is that i cannot find my switchbot bot with it, only the lock - i tried it with the active setting and everything. to troubleshoot i plugged in a USB BT Adapter and configured it to see if the bluetooth proxy is the issue - but even that way i only can find the lock, not the bot. i also cannot seem to find the bot hardware address anywhere in the logs with bluetooth logging active - i CAN find the lock of course.

i also already tried to reset the bot (and also removed battery etc.), also restarted HA during all of this several times.

i have activated verbose logging on the bluetooth proxy and can find it proxying packets:

[19:15:22][V][bluetooth_proxy:033]: Proxying packet from  - F0:B8:4C:1B:0C:DA. RSSI: -54 dB
[19:15:22][V][bluetooth_proxy:033]: Proxying packet from  - F0:B8:4C:1B:0C:DA. RSSI: -41 dB
[19:15:25][V][bluetooth_proxy:033]: Proxying packet from  - F0:B8:4C:1B:0C:DA. RSSI: -55 dB

i also have activated bluetooth logging in HA with and i have found a single instance of the MAC in it:

2023-02-01 19:10:06.679 DEBUG (MainThread) [homeassistant.components.bluetooth.manager] esp32-bluetooth-proxy-380c0c (08:b6:1f:38:0c:0c) [connectable]: F0:B8:4C:1B:0C:DA .... tx_power=-127, rssi=-45) match: {'switchbot'}

but yeah, it doesnt offer to set it up and if i try to add it via add integration → switchbot it only says “No unconfigured devices found”

is it not possible to add the normal switchbot bot via BT? is there anything else i can do to troubleshoot this? kind of reaching the end of my knowledge here :frowning: i guess i could set up a second esp32 with the mqtt-ble bridge, but would be pretty nice to have 1 for both devices, especially since they are next to each other anway…

if anyone ever runs into this issue too, i have just found the issue for me, Switchbot - v0.18.10 - No unconfigured devices found. · Issue #77179 · home-assistant/core · GitHub

there was an entry in .storage/core.config_entries from some previous installation (i am guessing via the mqtt bridge? not sure honestly), but after deleting the bot entries in there manually it was recognized again!