Syncthing Integration accessing API Token remotely?

Was looking to try the new syncthing integration , however have reached stumbling block where I cannot access as there is no GUI on my RPI4 HASSIO setup.

Is there an easy way to access this remotely to get the API Token. I am trying to access this via the http://:8384 from a different vlan (8384 has been allowed on the firewall) but this does not work.

Can anyone tell me if the above should work remotely in order to obtain the API token? If not is there any way around this? Perhaps syncthing is bound to only, or it is only bound the ip address of the NIC after entering and applying the API Token/ settings? Or I have missed something really obvious?!


There are several ways to do this. I would just change the config.xml file for the addon, so Syncthing runs on all addresses.

I don’t use HassOS, so can’t give detailed instructions on how to do this. Just writing from memory and things might have changed.

If you have a config file in the UI for the addon, look for the section that starts with “<gui enabled=…” - you will also find you api key here.

In case you gui is disabled - change gui enabled=“false” to “true”.
change listening address from “” to “”
and restart.

If no config file in the UI, you need to go into the filesystem on you installation and look for a folder named addons and find the correct subfolder for Syncthing - believe folder names are a strings of the addon-id.

The addon folder is not in you config folder, but in a folder on the same level.

Edit the file named config.xml and look for the part mentioned above. You might need to stop Syncthing before making changes.

1 Like

Many thanks for the advice. This does look like what is needed so it binds to all addresses. Have tried to get access to config.xml in the addons directory in order to do this however Visual Studio code addon (GUI) in HASSOS shows no files in the addons directory on the same level as the config directory. I have tried to gain “root” like access via ssh which i did have but looks like that is broken on my setup. Not sure why I cannot access addon files via Visual Studio code addon but can access everything in config directory, other than it being permissions settings. Will see if I can fix my broken root like access via SSH using pub/priv keys so i can try your suggestion. Thanks again.

If you install Portainer, remove the filters, so you see the HA containers. You can then access the console on the supervisor container and you have full access to you system.

Thanks for the suggestion Portainer gives me access to files that are hidden from VS code addon. Cannot see syncthing files in addons directory using supervisor container console access, I guess it’s because it’s an integration not an addon? Not sure where Integration files are or whether they have a similar file structure. I do have access to all my addons files that I have installed in the addons directory so can see the addons directory content.

Syncthing is both an integration and an addon. The integration connects to the addon.

If you can not find the Syncthing addon in the subfolder, it is not installed, and you can not get the integration to connect locally. You can still connect to other instances.

There is an hidden folder in you data dir called .storage with more info about you settings. The file named core.config_entries contains the settings for the integrations.

Looking and searching through core.config_entries there are no entries relating to settings mentioned previously or pertaining to Syncthing.

I guess I have to complete the below form in order for that information to populate Syncthing settings in core.config_entries?


I need to browse to in order to get to the action > settings bit where the API key is. then i can fill in the form above.

As you mentioned before, you do not have a syncthing addon in the folder, so it is not possible to connect.

You must install the addon first.

Add this repo = GitHub - Poeschl/Hassio-Addons: The repository for my Home Assistant Supervisor Add-ons. and install the addon. I do not use it myself, so can not verify if it and how it works.
Found the repo with a quick google search. There might be other and better suited repos.

You should also uncheck verification of ssl cert unless you use valid certs from e.g. Let’s Encrypt.

After the integration has a successful connection to you Syncthing instance, you will find the config info in core.config_entries.

1 Like

Finally got round to sorting this out. Again thanks for the help!

I think I am a victim of mind blindness :face_with_monocle:. Had I read this part in the docs:

The Syncthing integration allows you to monitor states of your synced folders from within Home Assistant and set up automations based on the information.

the rest would have made sense to me! After a break it all makes sense to me finally!

So now I understand this integration, integrates into a syncthing service running either locally or remotely. Not got local part working with the add-on that was suggested but don’t need to as I have the files syncing else where using the add-on that was suggested which is where I want to monitor anyway.

So backing up of Hassio file structure using the add-on suggested works and is what i really wanted and sensors are available to monitor my remote instance.

Many thanks