Synology Cameras not refreshing consistently in UI

Tags: #<Tag:0x00007f3263530308>

I am having an issue where my synology cameras are not refreshing consistently in the UI (lovelace and standard)

The cameras (10 of them) are connected successfully, and do stream successfully once clicked. They also continue to update every 10 seconds after opening the drill down - at least temporarily. But after some undetermined time, they no longer update to new images. Old images will even persist after a restart of home assistant and/or docker.

here is my config… thoughts?

camera:
  - platform: synology
    url: http://localhost:xxxx
    username: hass
    password: xxxxx

Hi Joe,

I have just moved over from Zoneminder to Surveillance Station today and have a similar issue as yourself.

Zoneminder the front end refreshes every 10 seconds and the drill down is live feed.
Synology the front end refreshes every 10 seconds and the drill down only appears to be 10 seconds as well.

I have noted a Pull request for fixing the mpeg stream for the camera component that was merged in to 0.82.

I am still on 0.81.5, but will be updating over the weekend.

I have now fixed my issue and Joe I hope this might point you in the right direction to fixing yours.

I first upgraded Hassio to 0.82.1, the streaming still did not work, so I figured it was my set up otherwise more people would be complaining.
I then upgraded the firmware on my Hikvision cameras to 5.5.8. Doing that enabled me to add them into Synology using the included config for Hikvision instead of rtsp.
After adding the camera in under the correct config they now are streaming correctly in home assistant (front end refreshes every 10 seconds and the drill down is live feed).

I hope this helps.

I am also using Synology and hikvision cameras (latest firmware and configured as the correct model in Synology) with homeassistant 0.82.1, but I cannot get the drill down to work at all. The front end seems to work okay, refreshing roughly every 10 seconds. I’ve tried a lot of different settings of primary and secondary streams but no luck. This was working more or less okay when I configured them as generic MJPG cameras, the only problem being that they were running lovelace into the ground and crashing my browser tab (they worked okay in the old UI though), but no dice with synology.

Is there any way to figure out why that drill down view isn’t working at all?