Synology Docker keeps restarting after 0.88.0 update

since the last couple of months I performed all HA updates without any problems.
Now 0.88 keeps restarting the docker container in a loop. Back to 0.87.1 as temp solution.
I tried also to delete the container and install it fresh, but no fun.
Is anybody experiencing the same issues?
How could this be diagnosed or the problem been isolated?

  • download Portainer in docker
  • run image
  • go http://IP:9000/ (IP is the IP of your nas)
  • set portainer
  • select image section
  • delete all HA image
  • back to the docker on synology
  • download HA image again

still not working, but thank you very much for recommending Portainer. I had in total 35 HA images and 22 volumes. I have deleted everything including my current working HA version.
Falling back to 0.87.1 again.

  1. Read changlog and verify you make any required change
  2. Any Log output?
  3. Disable all component (check default install work)
  4. I’d default OK, enable component 1 by 1

Any of above may point your issue
Likely restart because it crashing and you set container restart=always

many thanks for advice. I am back online, after starting from scratch and enabling components 1 by 1.
Was more time consuming as I thougt, because all home matic components have been given new names. Worth doing it…
I believe the custom component hue sensor was causing the issue.