Synology -> Docker -> Sky Connect - Lost at DSM 7.2-64570 Update 3

Hello there, I´m really lost, after updated DSM to the latest Firmware, I´ve lost the Sky Connect connection to my docker home assistant installation. And I can’t remember how I even managed the connection back then.

I´ve looked at the other threads about “Synology Docker Home Assistant USB connections” but no idea how this could help me…

When I ssh to my Synology, I can see

|__usb1 1d6b:0002:0404 09 2.00 480MBit/s 0mA 1IF (Linux 4.4.302+ xhci-hcd xHCI Host Controller 0000:00:15.0) hub
|__1-2 10c4:ea60:0100 00 2.00 12MBit/s 100mA 1IF (Nabu Casa SkyConnect v1.0 c09d9abb5741ed118eeb7aa7ccf2b06c)

Hello, Could you maybe share a bit more on your docker installation. Docker for synology DSM was recently updated to support docker compose and you might be able to add the command to passthrough the device there.

For Home assistant to have acces to the Sky connect it needs to be passed through to the docker container, normally this gets done with a option on the docker run command like: " –device /dev/ttyUSB0:/dev/ttyUSB1" What could have happened is that after the DSM update the port naming changed making the passthrough not work anymore.

Please check is there is a command somewhere in your docker container setup like above (probably under your environment variables) and if it is correct. Most likely the problem lies there. I hope I could help.

Thanks for your answer. Of course, with the last DSM update, the official Docker environment was removed and replaced by another container app, which probably also supports Docker, in principle everything works, except for Sky Connect.

Docker Compose I remember at the time, but not to have looked through, I have then definitely solved without.

I have in the container manager the possibility to set environment variables, but there I find nothing of any device and as I said I have unfortunately no memory where I had entered at that time.


Hi, I think you might be experiencing the problem described here:

Another alternative is to consider moving to Synology Virtual Machine Manager (VMM) which gives the advantages of access to HA Add-ons and I think the integration of USB devices is easier. There are several “how to” guides for this on Youtube,

@Jonah1970 a good hint, yes, I´ve added it as ZHA device in home assistant at that time. I think the last DSM update and the change of Docker to Container Manager broke my setup.

I can remember to have discarded at that time the variant about VMM, but of course I do not know any more where there my problem was, I must look again.

1 Like

Unfortunately I haven’t found yet what I have to do to remount the stick, I also have no idea which one it should be among all /dev/tty*.

/dev/tty    /dev/tty33  /dev/tty59  /dev/ttyb3  /dev/ttycf  /dev/ttyeb  /dev/ttyq7  /dev/ttyS1  /dev/ttytb  /dev/ttyv7  /dev/ttyx3  /dev/ttyyf
/dev/tty0   /dev/tty34  /dev/tty6   /dev/ttyb4  /dev/ttyd0  /dev/ttyec  /dev/ttyq8  /dev/ttys2  /dev/ttytc  /dev/ttyv8  /dev/ttyx4  /dev/ttyz0
/dev/tty1   /dev/tty35  /dev/tty60  /dev/ttyb5  /dev/ttyd1  /dev/ttyed  /dev/ttyq9  /dev/ttyS2  /dev/ttytd  /dev/ttyv9  /dev/ttyx5  /dev/ttyz1
/dev/tty10  /dev/tty36  /dev/tty61  /dev/ttyb6  /dev/ttyd2  /dev/ttyee  /dev/ttyqa  /dev/ttys3  /dev/ttyte  /dev/ttyva  /dev/ttyx6  /dev/ttyz2
/dev/tty11  /dev/tty37  /dev/tty62  /dev/ttyb7  /dev/ttyd3  /dev/ttyef  /dev/ttyqb  /dev/ttyS3  /dev/ttytf  /dev/ttyvb  /dev/ttyx7  /dev/ttyz3
/dev/tty12  /dev/tty38  /dev/tty63  /dev/ttyb8  /dev/ttyd4  /dev/ttyp0  /dev/ttyqc  /dev/ttys4  /dev/ttyu0  /dev/ttyvc  /dev/ttyx8  /dev/ttyz4
/dev/tty13  /dev/tty39  /dev/tty7   /dev/ttyb9  /dev/ttyd5  /dev/ttyp1  /dev/ttyqd  /dev/ttys5  /dev/ttyu1  /dev/ttyvd  /dev/ttyx9  /dev/ttyz5
/dev/tty14  /dev/tty4   /dev/tty8   /dev/ttyba  /dev/ttyd6  /dev/ttyp2  /dev/ttyqe  /dev/ttys6  /dev/ttyu2  /dev/ttyve  /dev/ttyxa  /dev/ttyz6
/dev/tty15  /dev/tty40  /dev/tty9   /dev/ttybb  /dev/ttyd7  /dev/ttyp3  /dev/ttyqf  /dev/ttys7  /dev/ttyu3  /dev/ttyvf  /dev/ttyxb  /dev/ttyz7
/dev/tty16  /dev/tty41  /dev/ttya0  /dev/ttybc  /dev/ttyd8  /dev/ttyp4  /dev/ttyr0  /dev/ttys8  /dev/ttyu4  /dev/ttyw0  /dev/ttyxc  /dev/ttyz8
/dev/tty17  /dev/tty42  /dev/ttya1  /dev/ttybd  /dev/ttyd9  /dev/ttyp5  /dev/ttyr1  /dev/ttys9  /dev/ttyu5  /dev/ttyw1  /dev/ttyxd  /dev/ttyz9
/dev/tty18  /dev/tty43  /dev/ttya2  /dev/ttybe  /dev/ttyda  /dev/ttyp6  /dev/ttyr2  /dev/ttysa  /dev/ttyu6  /dev/ttyw2  /dev/ttyxe  /dev/ttyza
/dev/tty19  /dev/tty44  /dev/ttya3  /dev/ttybf  /dev/ttydb  /dev/ttyp7  /dev/ttyr3  /dev/ttysb  /dev/ttyu7  /dev/ttyw3  /dev/ttyxf  /dev/ttyzb
/dev/tty2   /dev/tty45  /dev/ttya4  /dev/ttyc0  /dev/ttydc  /dev/ttyp8  /dev/ttyr4  /dev/ttysc  /dev/ttyu8  /dev/ttyw4  /dev/ttyy0  /dev/ttyzc
/dev/tty20  /dev/tty46  /dev/ttya5  /dev/ttyc1  /dev/ttydd  /dev/ttyp9  /dev/ttyr5  /dev/ttysd  /dev/ttyu9  /dev/ttyw5  /dev/ttyy1  /dev/ttyzd
/dev/tty21  /dev/tty47  /dev/ttya6  /dev/ttyc2  /dev/ttyde  /dev/ttypa  /dev/ttyr6  /dev/ttyse  /dev/ttyua  /dev/ttyw6  /dev/ttyy2  /dev/ttyze
/dev/tty22  /dev/tty48  /dev/ttya7  /dev/ttyc3  /dev/ttydf  /dev/ttypb  /dev/ttyr7  /dev/ttysf  /dev/ttyub  /dev/ttyw7  /dev/ttyy3  /dev/ttyzf
/dev/tty23  /dev/tty49  /dev/ttya8  /dev/ttyc4  /dev/ttye0  /dev/ttypc  /dev/ttyr8  /dev/ttyt0  /dev/ttyuc  /dev/ttyw8  /dev/ttyy4
/dev/tty24  /dev/tty5   /dev/ttya9  /dev/ttyc5  /dev/ttye1  /dev/ttypd  /dev/ttyr9  /dev/ttyt1  /dev/ttyud  /dev/ttyw9  /dev/ttyy5
/dev/tty25  /dev/tty50  /dev/ttyaa  /dev/ttyc6  /dev/ttye2  /dev/ttype  /dev/ttyra  /dev/ttyt2  /dev/ttyue  /dev/ttywa  /dev/ttyy6
/dev/tty26  /dev/tty51  /dev/ttyab  /dev/ttyc7  /dev/ttye3  /dev/ttypf  /dev/ttyrb  /dev/ttyt3  /dev/ttyuf  /dev/ttywb  /dev/ttyy7
/dev/tty27  /dev/tty52  /dev/ttyac  /dev/ttyc8  /dev/ttye4  /dev/ttyq0  /dev/ttyrc  /dev/ttyt4  /dev/ttyv0  /dev/ttywc  /dev/ttyy8
/dev/tty28  /dev/tty53  /dev/ttyad  /dev/ttyc9  /dev/ttye5  /dev/ttyq1  /dev/ttyrd  /dev/ttyt5  /dev/ttyv1  /dev/ttywd  /dev/ttyy9
/dev/tty29  /dev/tty54  /dev/ttyae  /dev/ttyca  /dev/ttye6  /dev/ttyq2  /dev/ttyre  /dev/ttyt6  /dev/ttyv2  /dev/ttywe  /dev/ttyya
/dev/tty3   /dev/tty55  /dev/ttyaf  /dev/ttycb  /dev/ttye7  /dev/ttyq3  /dev/ttyrf  /dev/ttyt7  /dev/ttyv3  /dev/ttywf  /dev/ttyyb
/dev/tty30  /dev/tty56  /dev/ttyb0  /dev/ttycc  /dev/ttye8  /dev/ttyq4  /dev/ttys0  /dev/ttyt8  /dev/ttyv4  /dev/ttyx0  /dev/ttyyc
/dev/tty31  /dev/tty57  /dev/ttyb1  /dev/ttycd  /dev/ttye9  /dev/ttyq5  /dev/ttyS0  /dev/ttyt9  /dev/ttyv5  /dev/ttyx1  /dev/ttyyd
/dev/tty32  /dev/tty58  /dev/ttyb2  /dev/ttyce  /dev/ttyea  /dev/ttyq6  /dev/ttys1  /dev/ttyta  /dev/ttyv6  /dev/ttyx2  /dev/ttyye

Unfortunately I can’t use VMM without deleting the complete NAS and reformatting it with Btrfs.

Thanks, SkyConnect with Home Assistant Docker in Synology (usb drivers) - #16 by oscarb solved my problem, the drivers were outdated, with the new ones for 7.2 everything works fine again…

so did you just get 7.2 modules and copy over and run same script? I cannot get skyconnect to appear under /dev/ at all :frowning:

it should be /dev/ttyU something

Yes, that solved my problem. I´m so sorry, I only updated the drivers. And I couldn´t find the part where I add the device to home assistant

yeah i tried for a few hours but gave up. i just shutdown my zigbee and moved over to FP2 sensors. (needed for four whole house so far) not bad.

Gosh I miss my zigbee network. It’s so frustrating how Synology lock out USB

Yes it is. Ever since DSM 7 came out I’ve been super worried about my system failing. I run in Docker and use zwave usb stick at two different houses. So far it’s been very stable. But

I have a spare Synology NAS for testing, So for version update or big service packs I apply them here first, copy my containers over and see if everything works. If so I’ll upgrade the primary NAS - and I guess it that fails - I can just run on the test NAS until I get it sorted. So while that seems like overkill having some backup hardware to test on (and as a backup for when the main system fails - everything breaks eventually) is a best practice if you are counting on the system to be running. I also have spare zwave sticks and NVM backups.

The other aspect, after years of working in SW, is I don’t like the computer to dictate my schedule. Meaning if I want to work for an hour on an update and the update fails I don’t want it to turn into a multi day marathon. So hence, I’m always preparing fall back plans, so that I don’t get involved in marathons and can easily and quickly get back to a working point at any time. VMs or docker really help by making the application portable between computers.

Am tempted to look into home assistant yellow or something like that to keep things simple and just use my sonology for media things