Synology nas docker appdaemon install with ssl hass - unable to connect to hass

I have been struggling for 3 days trying to install appdaemon3 on synology nas with docker. I am using below to create the image:
sudo docker run --name=dash -itd -p 5050:5050 --restart=always -e HA_URL=“” -e HA_KEY=“SECRET_KEY” -e DASH_URL=“” --mount type=bind,source=/volume1/docker/dash/config,target=/conf --mount type=bind,source=/volume1/docker/hass/config/ssl,target=/certs -e EXTRA_CMD="-D DEBUG" acockburn/appdaemon:latest

I have enabled the debug and below is the log

cp: cannot stat ‘/usr/src/app/conf/apps.yaml.example’: No such file or directory
2018-04-06 06:37:39.563510 INFO AppDaemon Version 3.0.0 starting
2018-04-06 06:37:39.563804 INFO Configuration read from: /conf/appdaemon.yaml
2018-04-06 06:37:39.563941 DEBUG AppDaemon Section: None
2018-04-06 06:37:39.564062 DEBUG HADashboard Section: None
2018-04-06 06:37:39.564880 INFO AppDaemon: Starting Apps
2018-04-06 06:37:39.565236 DEBUG AppDaemon: Creating worker threads …
2018-04-06 06:37:39.568088 DEBUG AppDaemon: Done
2018-04-06 06:37:39.568608 DEBUG AppDaemon: Entering run()
2018-04-06 06:37:39.569041 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin
2018-04-06 06:37:39.697350 INFO AppDaemon: HASS: HASS Plugin Initializing
2018-04-06 06:37:39.697900 INFO AppDaemon: HASS: HASS Plugin initialization complete
2018-04-06 06:37:39.698227 DEBUG AppDaemon: Starting utility loop
2018-04-06 06:37:39.698459 INFO Starting Dashboards
2018-04-06 06:37:39.706318 INFO API is disabled
2018-04-06 06:37:39.706639 DEBUG Start Loop
2018-04-06 06:37:40.083677 DEBUG AppDaemon: Event type:ha_disconnected:
2018-04-06 06:37:40.083981 DEBUG AppDaemon: {}
2018-04-06 06:37:40.084288 WARNING AppDaemon: HASS: Disconnected from Home Assistant, retrying in 5 seconds
2018-04-06 06:37:40.084426 WARNING AppDaemon: HASS: ------------------------------------------------------------
2018-04-06 06:37:40.084538 WARNING AppDaemon: HASS: Unexpected error:
2018-04-06 06:37:40.084683 WARNING AppDaemon: HASS: ------------------------------------------------------------
2018-04-06 06:37:40.169178 WARNING AppDaemon: HASS: Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/appdaemon/plugins/hass/”, line 189, in get_updates
“{}/api/websocket”.format(url), sslopt=sslopt
File “/usr/local/lib/python3.6/site-packages/websocket/”, line 494, in create_connection
websock.connect(url, **options)
File “/usr/local/lib/python3.6/site-packages/websocket/”, line 217, in connect
options.pop(‘socket’, None))
File “/usr/local/lib/python3.6/site-packages/websocket/”, line 76, in connect
sock = _ssl_socket(sock, options.sslopt, hostname)
File “/usr/local/lib/python3.6/site-packages/websocket/”, line 191, in _ssl_socket
sock = _wrap_sni_socket(sock, sslopt, hostname, check_hostname)
File “/usr/local/lib/python3.6/site-packages/websocket/”, line 168, in _wrap_sni_socket
File “/usr/local/lib/python3.6/”, line 407, in wrap_socket
_context=self, _session=session)
File “/usr/local/lib/python3.6/”, line 814, in init
File “/usr/local/lib/python3.6/”, line 1068, in do_handshake
File “/usr/local/lib/python3.6/”, line 689, in do_handshake
ssl.SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:777)
2018-04-06 06:37:40.169467 WARNING AppDaemon: HASS: ------------------------------------------------------------
2018-04-06 06:37:45.210214 DEBUG AppDaemon: Event type:ha_disconnected:

Really appreciate any inputs. Thanks.

Here is the appdaemon.yaml:

logfile: STDOUT
errorfile: STDERR
threads: 10
type: hass
ha_key: secret_key
#commtype: SSE
dash_dir: /conf/dashboards
dash_ssl_certificate: /certs/cert.pem
dash_ssl_key: /certs/privkey.pem

if you share yaml, please share it as codeblock, this way it is unreadable.

a few things:

  1. the ha_url needs to be an url that you can use in a browser to reach HA.
  2. ssl inside ha and ssl inside AD is asking for trouble.

if you want to reach your dashboards from outside your network, the better way is to install a proxyserver like nginx or caddy and setup your ssl there and remove it from ha and AD.
if you only use your dashboards inside your own network, then lose the ssl in AD.

There is a bug in the setup script that I have fixed for the next version. In the meantime if you manually setup your appdaemon.yaml as above it should work fine

OK, I got it working finally. Looks like the default appdaemon api port on synology nas has a conflict, so I had to go with 5010 instead. below is my working setup. Hope it will help someone.

Docker image:

sudo docker run --name=dash -itd -p 5050:5050 --restart=always -e HA_URL="" -e HA_KEY="xxxx" -e DASH_URL="" --mount type=bind,source=/volume1/docker/dash/config,target=/conf --mount type=bind,source=/volume1/docker/hass/config/ssl,target=/certs acockburn/appdaemon:latest


  logfile: STDOUT
  errorfile: STDERR
  threads: 10
  api_key: xxxx
  api_port: 5010
  api_ssl_certificate: /certs/cert.pem
  api_ssl_key: /certs/privkey.pem
      type: hass
      ha_key: xxxx
      cert_path: /certs/cert.pem
      cert_verify: false
  dash_dir: /config/appdaemon/dashboards
  dash_ssl_certificate: /certs/cert.pem
  dash_ssl_key: /certs/privkey.pem

@cpuram, short note to thank you for sharing your solution. I had exactly the same problem with the api port and Im running ubuntu 18.04 on nuc. So I think the conflict is general.
Anyway, changed as per your setting and all works.