Hello everyone. I’m living in Thailand and start in automation. Here we use a lot of SONOFF and LUMA products. I would like to install Home Assistant in my new Synology NAS. I watched many tutorial all the day and I’m stuck at the very beginning :frowning: I cannot install the package DOCKER. I cannot find it , despite I activated the BETA version. Can you please help? Any tutorial to install H.A in a Synology NAS with the new OSM7? thank you very much. Yann

1 Like

Hi and welcome to wonderful world of Home Assistant!
Before I try to answer, can you please share your Synology model?

Hi BeardedConti:-) thank you . My model is Synology DS218 play.

Realtek RTD1296SoC, 1,4Ghz, 4 core, 1Go.

I’m pretty sure that only the Synology “Plus” models support Docker and virtual machines.

As a caution, I bricked my old 216j trying to force-install Docker from some third-party web instructions…

Ho,ok i see. So cannot use Home Assistant?:frowning:

Officially, unfortunately no. j and play versions are different than + version.
You could try to sideload Docker on 218play, but as @vreihen said, there is always a chance for things to go wrong. And this would be also unsupported by both Synology and HA.
Biggest problem is CPU - ARM vs Intel.

Ok thank you. I fell so sad :frowning: well I need to find another alternative to manage my equipment with my NAS. Thank you all for’your kind help. Yann

A Raspberry Pi is most people’s choice for HA, although the supply seems to be limited due to the chip global shortage.

You can always upgrade your Synology to a plus model, which isn’t as expensive as it sounds since your current drives can be reused. I don’t know if DSM is stored on the disks or needs to be updated, but it may possibly be a transparent swap with no formatting.

I replaced my bricked 216j with a 918+ a few years ago, and maxed out the RAM to run Docker containers and virtual machines. I’m running HA OS on it now as a VM, as my production HA system. The only gotcha appears to be that Synology’s VMM platform does not remember a VM’s USB port mappings between NAS reboots, so I need to re-add the USB port for access to my Z-Wave stick on the rare occasions that my NAS is rebooted…

Thank you VReihen :slight_smile: will think about it :slight_smile:

Sorry I have a last question, as I’m really a beginner, what do you recommend: Raspberry or a new NAS ? Thank you very much :slight_smile:

More people seem to be using Raspberry Pi computers with HA OS than are using Synology NAS virtual machines. Consider it the better-supported hosting platform for HA, where most people can answer questions because they have the same exact system hardware.

My HA adventure started back in December during the holiday, and was initially only an evaluation install to see how it worked. I installed it as a VM on the 918+ NAS because I already had it in place, instead of ordering a Raspberry Pi. I decided to use HA as a replacement for my previous home automation platform, and just left it on the Synology since it has been running fine there…

Thank you very much for your feedback :slight_smile: ok I will try to find a raspberry here in Thailand :slight_smile: see you in a couple of weeks after my first installation, thank you again :slight_smile:

1 Like

Just to add on what @vreihen said, support is the same, installed volume base is lower - VM is HA OS, so there is no difference there. Everything that works on one will work on the other too.
I’ve been using it on both Synology and Rpi for years now. RPi3 for example is slower in terms of UI response, but still fast enough for automation and most of the things you will need.
RPi4 and VM on 918+/920+ should be same - works, no issues there.

1 Like

Hello Guys, so I received my Raspberry pi4 today and tried all day to install, here is what I done:
1: download haos_rpi4-64-7.4.img.xz.
2: Flash a drive with Balena
3: Plug the drive to raspberry, lan cable and power
4: wait around 1 hour
5: plug my Mac to the lan and open safari
6: type on my MacBook both http://homeassistant:8123/ and also try with http://homeassistant.local:8123/
7: nothing happen even after 10 minutes
8 check on both iPhone (find) or my server on safari, cannot find the device also.

Can you please help ?
thank you very much and have a nice day

First - please open new thread to keep things clean. But also, try to search for new IP address assigned to RPi by router. mDNS can but also doesn’t have to work.

1 Like

ok sorry, I will open a new topic :slight_smile: thank you