System Bridge Integration on Ubuntu - issues

Hi all,

I’ve been trying to get the System Bridge integration to work on my Ubuntu 22.04 machine, but having some issues.

With the recent version 3.4.4, and latest HA Core 2022.8.5.

  1. I’m not seeing the entities being reported in HA (error messages in links below)
  2. After a while, the System Bridge integration stops working on my Ubuntu Machine with the error

OSError: [Errno 24] Too many open files

Both of these issues have been documented here, but no solution yet.

I’m reaching out to the broader community, for hopes of getting some more information.

Is anybody using this integration with their Ubuntu 22.04 machine? thanks

Hi, just to let you know, you’re not alone.

I was looking for a simple to solution to monitor one of my VMs and another solution to shutdown one of my RaspberryPis remotely and found system bridge, which should be able to handle both :slight_smile:

I installed it on my Ubuntu VM. I took me sometime to figure out how to run it headless, but it’s running now and the API is working, but I can’t get the HA integration to work. I think it is related to this issue: System Bridge Entities not reporting to HA · Issue #77731 · home-assistant/core · GitHub
There is also a PR from October(!) Update systembridgeconnector to 3.4.8 by timmo001 · Pull Request #79732 · home-assistant/core · GitHub which is just waiting for a review and approve.

It’s sad to see that a simple PR takes that long :frowning:

@j_d Thanks for your input! Let’s hope these recent PRs will solve the issue.

By the way are you getting the too many open files error? After about maybe a day I get that issue when using the local API. But like you I don’t know what running headless means I have a Ubuntu machine without a monitor on it and no GUI but it is the Ubuntu desktop version so I don’t know what that has anything to do with it.

Also I’ve noticed quite a bit of disk activity on Ubuntu when this program runs. Are you experiencing this also?

headless means running system bridge without an UI. You can use the --no-gui flag for this. It is all written on the webpage: Running | System Bridge

Okay thanks for confirming then I’ve always been running headless then