System failure after blackout (zigbee)

I have a home assistant system with 70 pcs zigbee devices.

Today, was a 3-4 hours blackout. When we switch back the power, the system started, some devices isn’t work (ikea and xiaomi switches mainly) and the other devices (lights) work slowly. I am in despair, two month’s ago I had the same crash. So every blackout goes together with system failure. Why does the system not fully recover after a power cut?
Last time there was difficult to restore the system.

On what device is HA running?

Rpi4 2GB

Until blackout it worked properly, now I push the connecting button on some ikea on/off button, and some of them reconnected, and they switch on/off the lights, but some minutes later it stops working again. The lights is work strangely. For example the living room lamp include 5 lights. If I push on button 3 of them on, if I push it again the 4’th light turn on and push it again the 5’th light turn on (or not).

Many xiaomi devices do not fully conform to the zigbee standards. Because they don’t fully confirm, frequently they drop out and need to be re paired. Im assuming they are likely the cause of your issues, and when they dropped out stopped repeating and other devices behind them fell out.

There is a specific warning about them in zigbee2mqtt.

This isn’t your specific device, but the warning is here

https://www.zigbee2mqtt.io/devices/RTCGQ11LM.html#troubleshooting-device-stops-sending-messages-disconnects-from-network

There is a writeup about the issues with hubitat and xiomii devices. Although not home assistant, it’s message applies, especially that they are fussy about using certain devices as repeaters.

Check if you have any incompatible devices. You’d probably have to take them off the network. You might want to just get their xiaomi gateway for improved stability. The gateway can be integrated to Home Assistant.

Yes, I know the Xiaomi issue, but I use only passive xiaomi devices (push buttons and switches), the other devices are ikea lights, switches and motion sensors. Interestingly, The ikea passive switches don’t work. Maybe the hassio went wrong. Yesterday 3 ikea switces didn’t work. I can repair 2 of them, the last didn’t pairing. Now, in the morning I woke up, bu the living room ikea stybar switch didn’t turn on the light’s. I can turned on them from ha app. Ikea motion sensors doesn’t work too, but most of xioaomi devices communicate and work) with ha.

Are you using zha or zigbee2mqtt? Are there any log errors being generated? What coordinator/zigbee stick are you using?

Coordinator: Electrolama zzh (CC2652R Stick) with z2m addon.

Today I restore the last backup, reinstall the z2m addon, but the lost zigbee devices didn’t pairing. When I started the pairing method at hassio z2m addon and switch the zigbee devices (ikea on off and stybar switches) to pairing mode , nothing is happening. I see in the z2m log file (debug mode) that the operating mode switch to join mode. After that I switched to pairing mode an ikea on-off switch, an ikea stybar (these devices worked on system before blackout), and a Sonoff temperature sensor, but the log include nothing about pairing (only paired devices send messages) and naturally, the devices didn’t connect to the z2m. I tried to pair a new ikea power plug device, but the result is similar.

The coordinator is the same one I have and should be powerful enough to handle that many devices, and it’s recommended for z2m, so I doubt that is causing issues.

I have one device (Hampton Bay Fan) that is fussy after the power goes out. After a power outage, it loses its connection. I’ve found if it gains power before the machine running z2m is back on line, it won’t connect. Basically, the system has to have power before the device. I’ve added a UPS for the machine running Home Assistant and z2m that helps with short outages. Once the ups dies I have to wait for the computer to be on, then flip the breaker off and on for the seperate circuit with the fan to get the fan to reconnect.

I also have to always leave join mode on, which has helped keep devices that might temporarily disconnect to come back.

It’s also a bad sign things won’t reconnect that did before. Other thoughts are there is interference (the 2.4 ghz band zigbee uses is very crowded) and you can try a different channel. You would have to pair everything over if you do though. Here’s directions how to

https://www.zigbee2mqtt.io/advanced/zigbee/02_improve_network_range_and_stability.html#reduce-wi-fi-interference-by-changing-the-zigbee-channel.html

It’s also possible the power outage corrupted the information flashed to the coordinator, and you may have to reflash with the latest firmware.

If these things don’t fix it, short of always allowing join, and then attempting to pull and restore power to devices that aren’t reconnecting, I can’t think of other ideas and hopefully someone else can chime in with suggestions.

I am very grateful, rewriting the coordinator firmware solved the problem.

Thank you very much!

Hello,
sorry to reply to an old post.
I’m experiencing a similar issue (inconsistent devices behaviour after power cutoff) and I didn’t find a solution yet. How did you rewrite the firmware?

I also find that repairing devices sometimes improves if I disconnect and then reconnect the coordinator from the USB port. Secondly, if a device stubbornly won’t repair, try deleting it from Z2m or zha, then try to pair.