System Monitor Network sensors won't work on my Docker install

Good day!

I have HA installed using Docker on my Intel NUC NUC5CPYH. All the network-related sensors in System Monitor just don’t work at all.

I’ve read this article regarding the networking issue with a NUC (the network interface is named enp3s0 instead of eth0). The article is about and the solution points toward a config file which I don’t have in my HA container.

Is anyone aware of the solution? Right now, the sensors show a blank value in red circles:

and show this when grouped:

Here a part of my configuration.yaml file:

  - platform: systemmonitor
      - type: disk_use_percent
        arg: /
      - type: disk_use
        arg: /
      - type: disk_free
        arg: /
      - type: memory_use_percent
      - type: memory_use
      - type: memory_free
      - type: swap_use_percent
      - type: swap_use
      - type: swap_free
      - type: load_1m
      - type: load_5m
      - type: load_15m
      - type: network_in
        arg: enp3s0
      - type: network_out
        arg: enp3s0
      - type: throughput_network_in
        arg: enp3s0
      - type: throughput_network_out
        arg: enp3s0
      - type: packets_in
        arg: enp3s0
      - type: packets_out
        arg: enp3s0
      - type: ipv4_address
        arg: enp3s0
      - type: ipv6_address
        arg: enp3s0
      - type: processor_use
      - type: last_boot

Thank you for your help! I’m really clueless on that one…

My NUC uses the eno1 ethernet interface and that is what I use in my system sensor and it works fine for me.

I don’t use hassio tho, so maybe there is something flaky there.

have you tried to check what the actual network interface is?

try “ifconfig” or if that doesn’t work try “ip link show” at the command line.

Thank you for the reply! Much appreciated!

I’m not using Hassio too… I’m using the regular Home Assistant docker image running on a Ubuntu Server 18.04 host.

I’ve typed the following command in order to display all the available network adapters:

ifconfig -a | sed 's/[ \t].*//;/^$/d'

from which the response was:


only rthe enp3s0 adapter is resolving my actual internal IP address… I tried “docker0” and it didn’t work.

any other ideas?

Sorry, no I don’t.

your config looks like it’s correct with all of the info above. My config looks like yours and mine is working fine.

I’m not sure what else it could be.

1 Like

Thanks for trying!

I’ve even tried to put down the network interface and but it back on with “eth0” as the interface name.

I’ve done the following:

ip link set enp3s0 down           # Else you will get "Device or resource busy"
ip link set enp3s0 name eth0

but no chance. Anyone?

I was able to find out my ipv4_address with the following command on the console.

nmcli connection show (will list the “HassOS default” connection in use.)

Will look into it! Thanks! :slight_smile:

I used this command in the terminal:

ha network info

1 Like