System time is a few minutes off, how to sync?


I am new to HA and running HASSIO on an small PC. For some reason the time is always around 3 minutes off. This is really annoying because events are listed as “in two minutes” if I press a button. I want to sync the time so it does match with my MacBook, iPhone & co. Is there an easy fix?

Thank you,

You are not. HASSIO was retired over 3 years ago. You are likely running Home Assistant OS (HA OS for short).

Home Assistant should sync with an NTP server periodically. You can’t control this.

Do you have port 123 (the NTP port) blocked in your router?

@tom_l you are right, I am running HA OS :sweat_smile:

I checked my router settings and even created a new Port forwaring roule for HA, but it does not seem to change anything… I am really confused beacuse all of my other devices do not have this issue, all are running on the exact time.

I am also experiencing drift in my HA Yellow (with HAOS). A second or so per day. If I restart the HA Yellow hardware, it gets the correct time from my network. It does not stay synchronized.

Edit: Turns out new routers from Unifi no longer have a local NTP server. It seems every month I turn around and find a new way Ubiquiti has quietly removed features. Looking for something new for the future.