Systemmonitor Drive argument config

Good morning.

Configuration is - Synology NAS running Docker.

I am very new to this so i am sorry if this is a silly question.

I can monitor the local NAS drive with arg: / but my questions are:

  1. what is the argument to monitor the drive of a second NAS
  2. what is the argument to monitor the drive of a Windows PC.

Please remember i am new to this and will need full instructions.

many thanks in advance


Have you integrate it to HA? It should be auto-discovery.

You can also do a manual setup as instructed here-

For Windows, you can try-

Thank you for the quick reply. i have just checked and you are correct.

I didnt even notice the “volume1” drive space for the second NAS. #tick!

This just leaves the issue of the Windows PC?

You can try to use Open Hardware Monitor

Will have a look, thank you

Please note that you should give your Windows PC a static IP address, because after setting up you need to add this line to your configuration.yaml.

# Example configuration.yaml entry
  - platform: openhardwaremonitor
    host: IP_ADDRESS

All PC’s and NAS are static. I have HS running on a PC and it is good BUT hard drive is looking poor so want to get it on NAS

i think openhardwaremonitor needs “remote web server”. not sure how to get that running on Windows 10

Sorry, I don’t personally use openhardwaremonitor. For setting up remote web server, you can watch Allowing remote Web Server or FTP access in Windows 10 (2020).

Note: I don’t know if it works or not for openhardwaremonitor.

Goodluck :slight_smile:

i cant find out how to, or even if it is possible to run Remote Web Server on Windows 10.

You can read more on this thread-

Some users also experience an error in using openhardwaremonitor on Windows 10.

Great, that worked. Any idea on the config for multiple Windows PC’c? this didnt work



  • platform: openhardwaremonitor

Nice! Please use codeblock when you are pasting codes/YAML as written here. It will make it easier for others to see your codes - as with YAML you need to pay attention with indentation.

Maybe you can try-

  - platform: openhardwaremonitor
    host: IP_ADDRESS01
  - platform: openhardwaremonitor
    host: IP_ADDRESS02

All working, many thanks

Have a good day