Systemmonitor error loading component

I’m getting the following error when I startup home assistant. I have tried installing psutil manually. I have tried manually installing both 5.4.1 and 5.4.2 just to see if it was something fixed in 5.4.2. Both say they were successfully installed when I manually install them, but then homeassistant throws this error.

2017-12-12 13:55:18 ERROR (Thread-2) [homeassistant.util.package] Unable to install package psutil==5.4.1: Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-kxio5whg/psutil/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-c4vmxw0u-record/install-record.txt --single-version-externally-managed --prefix  --compile --user --prefix=" failed with error code 1 in /tmp/pip-build-kxio5whg/psutil/
2017-12-12 13:55:18 ERROR (MainThread) [homeassistant.setup] Not initializing sensor.systemmonitor because could not install dependency psutil==5.4.1
2017-12-12 13:55:18 ERROR (MainThread) [homeassistant.setup] Unable to prepare setup for platform sensor.systemmonitor: Could not install all requirements.

My systemmonitor config is as follows.

  - platform: systemmonitor
      - type: disk_use_percent
        arg: /
      - type: disk_free
        arg: /
      - type: memory_free
      - type: processor_use
      - type: last_boot
      - type: since_last_boot

Not trying to teach you to suck eggs, but you did do the manual install inside the venv? (assuming that is how you’re running HA)

Sorry, I was away from my computer for a while. Yes I was in my venv.

well under 0.60 it seems to work now.