Tailscale add-on - exit node & subnet access

I’ve successfully installed and set up the Tailscale addon on my Pi3 HA. However I don’t need nor want Exit node nor subnet access. It appears set by default within the addon and on my web UI I can only see “viewing” mode; no picture icon to login and change settings. How do I turn it off on the HA machine. I realise it also has to be enabled within the Tailscale portal to work but I have no reason to enable it at all. On other Linux machines these settings are off by default and a cli command through a terminal session to enable them.

Same issue here. Is is reasonable to just ignore these warnings? If I don’t authorize in the Tailscale Admin UI, then the default node-to-node communication will function just fine?

1 Like

I found the configuration options. They’re not within the web UI, they’re at the bottom of the addon page when using the app, at the top of the page when using a PC browser and hidden at the bottom of a tablet browser and pop up having scrolled to the bottom.

Select configuration and scroll to the bottom. Select “show unused optional configuration options”, select every option and then save. This populates the config file with everything ‘true’, then turn off or set false those that are not required. To disable subnet route access add a network, say 192.168.0.0/24, save, then edit the yaml and replace the network with “” (opposing square brackets).

Can you please add a scrreshot of your actual yaml, please?

I feel stupid but I can’t find the way to let him accept the opposing square brackets…
:frowning:

Thank you

Found my answer.
There must be a blank between the opposing square brackets

My config:

accept_routes: false
advertise_exit_node: false
advertise_routes: [ ]