Tapo C310 in Home Assistant

Hi. Im trying to add my Tapo C310 cameras to Home Assistant. Tried via the “add integrations → Tapo” but this failed. I also noticed that no cameras was listed as supported device to add this way. So how do i do this?

There is a custom iintegration in HACS for Tapo Cameras


I installed Home assistant and HACS directly on my Ubuntu PC intead since i realised the Home assistant in Umbrel i was using did not support HACS (i think). I managed to get the integrations needed for Tapo Cameras. This also included Frigate integration. Now Home assistant gets the stream of the cameras but no controls are available (greyd out) and i cant add configuration or sensors to the dashboard.

In Home assistant under integrations i go to Frigate and here i see the cameras and all the options. But as i said they are greyd out and pressing add to dashboard gives me error: “No views in this dashboard.”

Pressing the little arrow takes me to the Integrations configuration for Frigate and there i noticed "
Enable WebRTC for camera streams" and options to add RTSP URL. I added the same as in Frigate Config file and then all controls went from just unavailable to flicker between unavailable and available (but not possible to use them since just flickering) also, the vide stream itself flickers from recording to unavialable in the same way. (as before entering this config it was steady working fine.

I interpret this as some kind of conflict? But not able to figure it out. Any help apprechiated!

I tried to remove the Frigate integration and added again. Still flickering. Regardless of configuration (removed the RTSP URL and Enable WebRTC for camera streams)…