Tapo integration issues


I’m trying to integrate my 2 Tapo cameras with the tapo integration (Tapo - Home Assistant) but get problems.
But I’m almost sure the problem doesn’t come from Home Assistant. I want to share my experience so other people may be interested with the information I will provide below if they have issues.

I’m on Core version 2024.2.4 but had the same problems with previous versions.

I bought a Tapo C310 a few months ago.

For privacy reasons, I blocked the access to internet like this :

  1. block DNS queries in Pi-Hole
  2. deny rule in the firewall of my Synology router

Result :
_ unable to connect to the camera from outside home with the Tapo Android application (expected)
_ unable to connect to the camera from outside home with the Tapo Android application BUT connected home via VPN (unexpected) (I can access all my others devices like a NAS, an android TV box, etc)
_ able to stream via VPN with the tinyCam Android application
_ able to add the camera in Home Assistant with the Tapo integration

Recently I bought a Tapo c225 and since then I started having a lot of issues.

Disabling the deny rule on the router :
_ both cameras show fine in the Tapo Android application
_ both cameras show fine in the tinyCam Android application
_ Home Assistant integration works fine

Then I restarted Home Assistant and the Tapo C310 shows as “unavailable”.
I need to remove the device from the integration and add it again. When I’m asked to type the Cloud password, it is not accepted.
I tried many times, restarted the cameras and Home Assistant and suddently I was able again to add it to Home Assistant.

When I activate the deny rule for the C225, the cameras still works fine in the Tapo Adroid app, tinyCam Android app and Home Assistant even though I cannot connect sometimes in Home Assistant and the Tapo Android app.
It is worse with the C310. I cannot connect via the Tapo Android app and it shows as “unavailable” in Home Assistant.
And I don’t understand why as it was working fine until I installed the C225.

Something else : in the Tapo integration, I see 2 devices when clicking on the integration from the integrations page, the c225 that is fine and the c310 (it is displayed : “Needs attention. Failed setup, will retry”).
And the deny firewall rules are not enabled !

So I remove the c310 device from the Tapo entity and tried to add it and it failed when asked to provide the cloud password.
But the camera shows fine in the Tapo Android application.

One again I restarted Home Assistant.
Deny firewall rule still disabled and allowed DNS queries on Pi-Hole.

This is making me become crazy.

I hope this information will allow others to know there are not alone with that kind of problems.


same issue, using c200 and c310 :upside_down_face:

Also having same problem. Event connecting PC running HA (hyper-v) to same WIFI network as camera does not work.