Tapo LED strips not turning on

HI there guys,

I have create the below automation:

alias: Salty lamp
description: "Salt lamp acts as a night light in the ensuite between 7pm & 7am "
use_blueprint:
  path: Blackshome/sensor-light.yaml
  input:
    motion_trigger:
      - binary_sensor.ensuite_motion_sensor_occupancy_5
    light_switch:
      entity_id:
        - switch.ensuite_lamp_switch
        - light.under_bed_lights
    dynamic_lighting_max_lux: 900
    dynamic_lighting_step_value: 87
    include_time: time_enabled
    after_time: "16:30:00"
    before_time: "07:00:00"
    time_delay: 0.5
    include_light_control:
      - use_brightness
    include_night_lights: night_lights_enabled
    night_lights:
      entity_id: light.under_bed_lights
    night_time_delay: 0.5
    include_night_light_control:
      - use_brightness
    night_light_brightness: 10
    night_lights_conditions:
      - time_enabled
    night_lights_after_time: "22:00:00"
    night_lights_before_time: "06:00:00"

This switch part of it turns on no worries however the LED strip will only sometimes turn on. However, on the home assistant app or the Tapo app it states the strip as been in the on position but there is no light emitting. If i open up the light control on HA or Tapo app and adjust the light brightness by 1% it will then turn on.

I have tried other automations as well however i still get the same issue with the light not actually emitting light.
So i created an automation in the tapo App itself doing the same thing and its works flawlessly everytime. Not sure if this is a common issue with Tapo LEDs or i am doing something wrong.

Thank you