TasmoAdmin inaccessible via HomeAssistant interface

Since a few months, I can’t access the TasmoAdmin page from the Home Assistant interface.
It happens both when I connect via DuckDNS as well as when I access Home Assistant via the local IP address.

The TasmoAdmin icon is displayed in the menu bar on the left side, but when I click it I get a screen with the following message: myname.duckdns.org uses an unsupported protocol. (where myname shows my own name)
I see this both when I log on via DuckDNS as well as when I log on via the local IP address (where I would expect the interface has nothing to do with DuckDNS). The rest of the whole Home Assistant interface works flawlessly, both via DuckDNS as well as via the local IP address. It’s just TasmoAdmin that I can’t access.

I’ve looked for solutions for a while already, because there’s no way I can access the configuration page of my connected Tasmota devices. I’ve found similar complaints, but not how to solve it in Home Assistant (e.g. No 0.15.1 update with HA core-2021.10.0 - githubmemory).

My current installed version is 0.15.0. According to the Log, this is the latest and greatest:
Add-on version: 0.15.0
You are running the latest version of this add-on.
System: Home Assistant OS 6.6 (armv7 / raspberrypi4)
Home Assistant Core: 2021.10.6
Home Assistant Supervisor: 2021.10.8

The Tasmota devices are all working correctly, but I’m locked-out of the interface where I can configure them. So, it will become an issue for me.

I’ve uninstalled and re-installed the TasmoAdmin Add-On, bit with the exact same result…

Does anybody know if this is indeed still the latest and greatest? When Googling, it seems like a newer version should be available.
Does anybody know another thing that can cause me the be locked-out of the TasmoAdmin interface?

I have not come any further with this, unfortunately.

When I go to Supervisor → TasmoAdmin and then select Open Web UI, I get the following error:
The client and server don’t support a common SSL protocol version or cipher suite

When searching I find some other people running into issues, where upgrading from 32 bit HASSIO to 64 bit HASSIO seems to have solved the issue.

Can someone let me know if this indeed is something I should try?


Since version core-2021.11.5 it started working again…

I guess some influential people have been reading my discussion with myself on this forum :wink:

Thanks all!

I am running HomeAssistant on a Pi 4, core 2023.10.3, supervisor 2023.11.6. I access my HA both remotely/locally with my duckdns address. Fr a while now I havent been able to access TasmoAdmin. I have tried searching for answers but havent found them. Any ideas anyone?