Tasmota Buttons as automation trigger

Hi everyone.

I am shifting from IOBroker to HA. I now stuck on a problem with my tasmota shutters.

I am using the tasmota-integration. HA allready registered the buttons as automation-triggers(with short_press, double_press and so on). Unfortunately if I configure a automation and push the button, the automation is not triggerd (i tried one press, two, long, different button).

I have no idea, what I did wrong. Maybe someone can help me here?

Tasmota config:
SetOption80 1
Shuttermode 1
Interlock ON
SetOption73 1
SetOption114 1

ShutterButton1 3 - - - - 1 1 1 - 1 <— because I want to use button3, i also tried it with button 1 and 2

I also tried:
ShutterButton1 3 - - - - - - - - 1

Because the following Options are mentiond in the Tasmota-docs to have an effect:
SetOption1 0
SetOption11 0
SetOption13 0

best regards

I have the solution. ShutterButton1 3 xxxxxxxxx was the problem.
In my case Tasmota published {“Shutter1”:{“Button3”:2}}. If ShutterButton1 3 is not defined, it publishs {“Button3”:{“Action”:“DOUBLE”}} and now it works.

Can be closed.