Tasmota DHT11 slow temp updates in HA

First post here but been lurking for a bit. Anyway, glad to be apart of the community and expand my knowledge (hopefully share).

On to my problem.

Simply, I have a sonoff flashed with tasmota and a DHT11 attached. Going directly to the tasmota UI, I see temps update frequently (~1 min) but within HA, I see it only update after 30 or a lot longer (hours). Is there a way to adjust this update frequency?

I don’t need high fidelity but if I can get updates more frequently then I would like to see that (maybe every 10min)

I attempted to adjust the telemetry interval via console but that looks to be specific to syslog (from what I can tell). I just ordered a DHT22 and another DHT11 to Test out. So any ideas would help.

Sonoff basic
Tasmota 6.1.1
Hassio 0.76.2
MQTT 1.4.15

If you also use sleep to save energy then you need much smaller teleperiod.

I use teleperiod of 10 for the maximum sleep period of 250 and mine updates about every minute.

1 Like

Teleperiod was the option which I needed to change. Once changed, thing are reporting in more frequently.

Thank you Crhass