Tasmota does not recognize anything except RF Bridge after converting to a Pi4b

I’m running Home Assistant on a Pi3. Mosqito and Tasmota work slowly but smoothly, recognizing all devices through the connected Sonoff RF Bridge. The recognized devices are also controlled almost flawlessly through automations. All updates have been loaded, the system is up to date. Since the system runs very slowly on the Pi3b, I want to transfer it to a Pi4b. For this purpose, I flashed a basic version of HA onto a card and then performed a restore of the complete backup. However, Tasmota only recognizes 1 device afterwards: the RF Bridge, nothing else. There are no error messages. Even the attempt to install a basic version of HA and then reinstall mosqito and Tasmota does not work.
I also compared all configurations between the version on the Pi3b and the Pi4b. Everything matches.
I’m afraid I need competent advice.
Thanks alot in advance!

Guess from experience: Different RPi, different MAC address, DHCP, so different IPv4. Clients can’t connect to the server as embedded devices don’t tend to use mDNS.


  • Change the client devices MQTT IPv4 (the shell on Tasmota devices is great for this)
  • Change the HASS network settings to the old IPv4 and static
  • Change the HASS network settings to a new memorable static IPv4 (like .200 out of the DHCP pool range)

Thx! I’ll check this issue…

There might be a code to enter in the Tasmota terminal for the RF Bridge to accept the codes you want.