Tasmota : It's possible to flash Sonoff 1 Channel Inching/Self-Locking Relay Board?

It’s possible to flash Sonoff like this (1 Channel Inching/Self-Locking Relay Board?) ?? can you help me, please!
sonoff2

That looks like PSF-B04 module, so yes you can

I’ve been trying for two days with tasmotizer but nothing! When I click on TASMOTIZE it only downloads and then freezes, it does not erase the previous driver and does not make a backup, as if the connections to TX and RX were broken (I checked the wires!)… Have any of you managed to flash this particular model?

You might have a charge only usb wire. You might not have the drivers loaded for the usb to serial adapter. You may have set the power wrong on the adapter. You may not have the right adapter. You may be using linux and don’t have the usb port set to write. You may not have set the device to boot loader mode…

Those have all happened to me. If you like I can probably think of some more.

Thank you so much! In the meantime I’ll focus on these…

Not this particular board but with the same module.
This is from one when i just started flashing custom firmware and it was successful.
Just make sure all the wires are soldered to the right pins

it still doesn’t work! :rage: do you think I should abandon TASMOTIZER and go back to the old Arduino???

this my ESPXXXX…

espxxxx

It’s not tasmotizer, you still can’t get it to download mode
You might need to show how you wired the pins to the uart

Aren’t there any of you who need a dry contact Sonoff? You could buy it on Aliexpres and then let me understand how to flash it :wink:

from left to right: Ground - none - 3.3V -TX -RX - none
(with RX and TX reversed on the ESP)

GND to gpio00 on the chip?

Yes. I use the center button. contacts already tested

Unless something’s connected to the tx/rx from the pcb, you might need to cut the trace or just desolder the chip

I close-ed up on that thing.
It looks like it also does rf433 and has another radio chip and antenna for that. That will be connected seriallly to the main esp somewhere.
So get a pinout diagram from somewhere, probably the blakadder site I linked, and see what pins are where. as @ferbulous mentioned, you may have to remove it to flash it if the rx-tx are being used by that rf chip.

thanks for the advice!!! However, I don’t see anything connected towards RX and TX

since I don’t think I’ll ever use RF433, maybe I could cut out the whole part that goes behind the relay, towards the black antenna. what do you think?

I also tried this, excluding the entire RF433 part, including the antenna. Luckily the sonoff still works, but Tasmotizer still doesn’t see it!

latest updates… I tried to flash the sonoff with Arduino. Unlike Tosmotizer, during the initial phase of the process with Arduino the LED near the relay flashes (!!!), so the PC and the sonoff are somehow visible!
But then the usual incommunicability error appears:


esptool.py v2.8
Serial port COM4
Connecting........_____....._____....._____....._____....._____....._____....._____
Traceback (most recent call last):
  File "C:\Users\name_user\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.6.1/tools/upload.py", line 69, in <module>
    esptool.main(cmdline)
  File "C:/Users/name_user/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.6.1/tools/esptool\esptool.py", line 2890, in main
    esp.connect(args.before)
  File "C:/Users/name_user/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.6.1/tools/esptool\esptool.py", line 483, in connect
    raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\default: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\default
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\libesp32: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\libesp32
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\libesp32_div: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\libesp32_div
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\libesp32_eink: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\libesp32_eink
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\libesp32_ml: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\libesp32_ml
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_audio: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_audio
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_basic: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_basic
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_deprecated: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_deprecated
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_display: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_display
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_div: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_div
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_i2c: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_i2c
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_rf: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_rf
Invalid library found in C:\Users\name_user\Documents\Arduino\libraries\lib_ssl: Nessun header file (.h) trovato in C:\Users\name_user\Documents\Arduino\libraries\lib_ssl

I think you might need to desolder the chip as a last resort. I had an esp32c3 that just refuses to go to download and I have no idea why (desoldered from the pcb)